Mission and Overview
NVD is the U.S. government repository of standards based vulnerability management data. This data enables automation of vulnerability management, security measurement, and compliance (e.g. FISMA).
Resource Status
NVD contains:

Last updated: 10/22/2014 6:59:44 PM

CVE Publication rate: 53.23

Email List

NVD provides four mailing lists to the public. For information and subscription instructions please visit NVD Mailing Lists

Workload Index
Vulnerability Workload Index: 15.33
About Us
NVD is a product of the NIST Computer Security Division and is sponsored by the Department of Homeland Security's National Cyber Security Division. It supports the U.S. government multi-agency (OSD, DHS, NSA, DISA, and NIST) Information Security Automation Program. It is the U.S. government content repository for the Security Content Automation Protocol (SCAP).

National Cyber Awareness System

Vulnerability Summary for CVE-2004-0381

Original release date: 05/04/2004
Last revised: 03/07/2011
Source: US-CERT/NIST

Overview

mysqlbug in MySQL allows local users to overwrite arbitrary files via a symlink attack on the failed-mysql-bugreport temporary file.

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score: 2.1 (LOW) (AV:L/AC:L/Au:N/C:N/I:P/A:N) (legend)
Impact Subscore: 2.9
Exploitability Subscore: 3.9
CVSS Version 2 Metrics:
Access Vector: Locally exploitable
Access Complexity: Low
Authentication: Not required to exploit
Impact Type: Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

External Source: MANDRAKE
Name: MDKSA-2004:034
External Source: BUGTRAQ
Name: 20040324 mysqlbug tmpfile/symlink vulnerability.
External Source: OVAL
Name: oval:org.mitre.oval:def:11557
External Source: REDHAT
Name: RHSA-2004:569
External Source: BID
Name: 9976
Type: Advisory; Patch Information
External Source: XF
Name: mysql-mysqlbug-symlink(15617)
Type: Advisory
External Source: DEBIAN
Name: DSA-483
External Source: REDHAT
Name: RHSA-2004:597
External Source: BUGTRAQ
Name: 20040414 [OpenPKG-SA-2004.014] OpenPKG Security Advisory (mysql)
Type: Advisory; Patch Information
External Source: GENTOO
Name: GLSA-200405-20
External Source: CIAC
Name: P-018

References to Check Content

Identifier: oval:org.mitre.oval:def:11557
Check System: http://oval.mitre.org/XMLSchema/oval-definitions-5

Vulnerable software and versions

Skip Navigation Links.
Collapse Configuration 1Configuration 1
Collapse OROR
* cpe:/a:mysql:mysql:3.20.32a
* cpe:/a:mysql:mysql:3.22.26
* cpe:/a:mysql:mysql:3.22.27
* cpe:/a:mysql:mysql:3.22.28
* cpe:/a:mysql:mysql:3.22.29
* cpe:/a:mysql:mysql:3.22.30
* cpe:/a:mysql:mysql:3.22.32
* cpe:/a:mysql:mysql:3.23.10
* cpe:/a:mysql:mysql:3.23.2
* cpe:/a:mysql:mysql:3.23.22
* cpe:/a:mysql:mysql:3.23.23
* cpe:/a:mysql:mysql:3.23.24
* cpe:/a:mysql:mysql:3.23.25
* cpe:/a:mysql:mysql:3.23.26
* cpe:/a:mysql:mysql:3.23.27
* cpe:/a:mysql:mysql:3.23.28
* cpe:/a:mysql:mysql:3.23.28:gamma
* cpe:/a:mysql:mysql:3.23.29
* cpe:/a:mysql:mysql:3.23.3
* cpe:/a:mysql:mysql:3.23.30
* cpe:/a:mysql:mysql:3.23.31
* cpe:/a:mysql:mysql:3.23.32
* cpe:/a:mysql:mysql:3.23.33
* cpe:/a:mysql:mysql:3.23.34
* cpe:/a:mysql:mysql:3.23.36
* cpe:/a:mysql:mysql:3.23.37
* cpe:/a:mysql:mysql:3.23.38
* cpe:/a:mysql:mysql:3.23.39
* cpe:/a:mysql:mysql:3.23.40
* cpe:/a:mysql:mysql:3.23.41
* cpe:/a:mysql:mysql:3.23.42
* cpe:/a:mysql:mysql:3.23.43
* cpe:/a:mysql:mysql:3.23.44
* cpe:/a:mysql:mysql:3.23.45
* cpe:/a:mysql:mysql:3.23.46
* cpe:/a:mysql:mysql:3.23.47
* cpe:/a:mysql:mysql:3.23.48
* cpe:/a:mysql:mysql:3.23.49
* cpe:/a:mysql:mysql:3.23.5
* cpe:/a:mysql:mysql:3.23.50
* cpe:/a:mysql:mysql:3.23.51
* cpe:/a:mysql:mysql:3.23.52
* cpe:/a:mysql:mysql:3.23.53
* cpe:/a:mysql:mysql:3.23.53a
* cpe:/a:mysql:mysql:3.23.54
* cpe:/a:mysql:mysql:3.23.54a
* cpe:/a:mysql:mysql:3.23.55
* cpe:/a:mysql:mysql:3.23.56
* cpe:/a:mysql:mysql:3.23.58
* cpe:/a:mysql:mysql:3.23.8
* cpe:/a:mysql:mysql:3.23.9
* cpe:/a:mysql:mysql:4.0.0
* cpe:/a:mysql:mysql:4.0.1
* cpe:/a:mysql:mysql:4.0.10
* cpe:/a:mysql:mysql:4.0.11
* cpe:/a:mysql:mysql:4.0.11:gamma
* cpe:/a:mysql:mysql:4.0.12
* cpe:/a:mysql:mysql:4.0.13
* cpe:/a:mysql:mysql:4.0.14
* cpe:/a:mysql:mysql:4.0.15
* cpe:/a:mysql:mysql:4.0.18
* cpe:/a:mysql:mysql:4.0.2
* cpe:/a:mysql:mysql:4.0.3
* cpe:/a:mysql:mysql:4.0.4
* cpe:/a:mysql:mysql:4.0.5
* cpe:/a:mysql:mysql:4.0.5a
* cpe:/a:mysql:mysql:4.0.6
* cpe:/a:mysql:mysql:4.0.7
* cpe:/a:mysql:mysql:4.0.7:gamma
* cpe:/a:mysql:mysql:4.0.8
* cpe:/a:mysql:mysql:4.0.8:gamma
* cpe:/a:mysql:mysql:4.0.9
* cpe:/a:mysql:mysql:4.0.9:gamma
* cpe:/a:mysql:mysql:4.1.0.0
* cpe:/a:mysql:mysql:4.1.0:alpha
* Denotes Vulnerable Software
Changes related to vulnerability configurations

Technical Details

Vulnerability Type (View All)