Mission and Overview
NVD is the U.S. government repository of standards based vulnerability management data. This data enables automation of vulnerability management, security measurement, and compliance (e.g. FISMA).
Resource Status
NVD contains:

Last updated: 9/22/2014 12:24:21 AM

CVE Publication rate: 29.17

Email List

NVD provides four mailing lists to the public. For information and subscription instructions please visit NVD Mailing Lists

Workload Index
Vulnerability Workload Index: 9.12
About Us
NVD is a product of the NIST Computer Security Division and is sponsored by the Department of Homeland Security's National Cyber Security Division. It supports the U.S. government multi-agency (OSD, DHS, NSA, DISA, and NIST) Information Security Automation Program. It is the U.S. government content repository for the Security Content Automation Protocol (SCAP).

National Cyber Awareness System

Vulnerability Summary for CVE-2007-0454

Original release date: 02/05/2007
Last revised: 03/07/2011
Source: US-CERT/NIST

Overview

Format string vulnerability in the afsacl.so VFS module in Samba 3.0.6 through 3.0.23d allows context-dependent attackers to execute arbitrary code via format string specifiers in a filename on an AFS file system, which is not properly handled during Windows ACL mapping.

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score: 7.5 (HIGH) (AV:N/AC:L/Au:N/C:P/I:P/A:P) (legend)
Impact Subscore: 6.4
Exploitability Subscore: 10.0
CVSS Version 2 Metrics:
Access Vector: Network exploitable
Access Complexity: Low
Authentication: Not required to exploit
Impact Type: Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service

Vendor Statements (disclaimer)

Official Statement from Red Hat (05/14/2007)
Not vulnerable. These issues affect the AFS ACL module which is not distributed with Samba in Red Hat Enterprise Linux 2.1, 3, 4, or 5.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

External Source: VUPEN
Name: ADV-2007-0483
Type: Advisory
External Source: MANDRIVA
Name: MDKSA-2007:034
External Source: SECUNIA
Name: 24151
Type: Advisory
External Source: BUGTRAQ
Name: 20070207 rPSA-2007-0026-1 samba samba-swat
External Source: CONFIRM
Name: http://us1.samba.org/samba/security/CVE-2007-0454.html
External Source: CONFIRM
Name: https://issues.rpath.com/browse/RPL-1005
External Source: OSVDB
Name: 33101
External Source: SECUNIA
Name: 24046
Type: Advisory
External Source: SECUNIA
Name: 24145
Type: Advisory
External Source: DEBIAN
Name: DSA-1257
External Source: TRUSTIX
Name: 2007-0007
External Source: SECUNIA
Name: 24067
Type: Advisory
External Source: SECTRACK
Name: 1017588
External Source: XF
Name: samba-afsacl-format-string(32304)
External Source: SECUNIA
Name: 24101
Type: Advisory
External Source: UBUNTU
Name: USN-419-1
External Source: SECUNIA
Name: 24060
Type: Advisory
External Source: GENTOO
Name: GLSA-200702-01
External Source: SLACKWARE
Name: SSA:2007-038-01
External Source: BUGTRAQ
Name: 20070205 [SAMBA-SECURITY] CVE-2007-0454: Format string bug in afsacl.so VFS plugin
US-CERT Vulnerability Note: CERT-VN
Name: VU#649732
External Source: SECUNIA
Name: 24021
Type: Advisory
External Source: BID
Name: 22403
Type: Patch Information
External Source: OPENPKG
Name: OpenPKG-SA-2007.012

Vulnerable software and versions

Skip Navigation Links.
Collapse Configuration 1Configuration 1
Collapse OROR
* cpe:/o:debian:debian_linux:3.0
* cpe:/o:debian:debian_linux:3.0::alpha
* cpe:/o:debian:debian_linux:3.0::arm
* cpe:/o:debian:debian_linux:3.0::hppa
* cpe:/o:debian:debian_linux:3.0::ia-32
* cpe:/o:debian:debian_linux:3.0::ia-64
* cpe:/o:debian:debian_linux:3.0::m68k
* cpe:/o:debian:debian_linux:3.0::mips
* cpe:/o:debian:debian_linux:3.0::mipsel
* cpe:/o:debian:debian_linux:3.0::ppc
* cpe:/o:debian:debian_linux:3.0::s-390
* cpe:/o:debian:debian_linux:3.0::sparc
* cpe:/o:debian:debian_linux:3.1
* cpe:/o:debian:debian_linux:3.1::alpha
* cpe:/o:debian:debian_linux:3.1::amd64
* cpe:/o:debian:debian_linux:3.1::arm
* cpe:/o:debian:debian_linux:3.1::hppa
* cpe:/o:debian:debian_linux:3.1::ia-32
* cpe:/o:debian:debian_linux:3.1::ia-64
* cpe:/o:debian:debian_linux:3.1::m68k
* cpe:/o:debian:debian_linux:3.1::mips
* cpe:/o:debian:debian_linux:3.1::mipsel
* cpe:/o:debian:debian_linux:3.1::ppc
* cpe:/o:debian:debian_linux:3.1::s-390
* cpe:/o:debian:debian_linux:3.1::sparc
* cpe:/o:mandrakesoft:mandrake_linux:2006
* cpe:/o:mandrakesoft:mandrake_linux:2006::x86_64
* cpe:/o:mandrakesoft:mandrake_linux_corporate_server:3.0
* cpe:/o:mandrakesoft:mandrake_linux_corporate_server:3.0::x86_64
* cpe:/o:mandrakesoft:mandrake_linux_corporate_server:4.0
* cpe:/o:mandrakesoft:mandrake_linux_corporate_server:4.0::x86_64
* cpe:/o:mandrakesoft:mandrake_linuxsoft_2007
* cpe:/o:mandrakesoft:mandrake_linuxsoft_2007:::x86_64
Collapse Configuration 2Configuration 2
Collapse OROR
* cpe:/a:samba:samba:3.0.10
* cpe:/a:samba:samba:3.0.11
* cpe:/a:samba:samba:3.0.12
* cpe:/a:samba:samba:3.0.13
* cpe:/a:samba:samba:3.0.14
* cpe:/a:samba:samba:3.0.14a
* cpe:/a:samba:samba:3.0.20
* cpe:/a:samba:samba:3.0.20a
* cpe:/a:samba:samba:3.0.20b
* cpe:/a:samba:samba:3.0.21
* cpe:/a:samba:samba:3.0.21a
* cpe:/a:samba:samba:3.0.21b
* cpe:/a:samba:samba:3.0.21c
* cpe:/a:samba:samba:3.0.22
* cpe:/a:samba:samba:3.0.23d
* cpe:/a:samba:samba:3.0.6
* cpe:/a:samba:samba:3.0.7
* cpe:/a:samba:samba:3.0.8
* cpe:/a:samba:samba:3.0.9
* Denotes Vulnerable Software
Changes related to vulnerability configurations

Technical Details

Vulnerability Type (View All)
  • Format String Vulnerability (CWE-134)