National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2004-0802 Detail

Description

Buffer overflow in the BMP loader in imlib2 before 1.1.2 allows remote attackers to execute arbitrary code via a specially-crafted BMP image, a different vulnerability than CVE-2004-0817.

Source:  MITRE
Description Last Modified:  12/31/2004

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 5.1 MEDIUM
Vector: (AV:N/AC:H/Au:N/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 4.9


Access Vector (AV): Network
Access Complexity (AC): High
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Victim must voluntarily interact with attack mechanism
Provides user account access
Allows unauthorized disclosure of information
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://cvs.sourceforge.net/viewcvs.py/enlightenment/e17/libs/imlib2/ChangeLog?rev=1.20&view=markup
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000870 Patch
http://sunsolve.sun.com/search/document.do?assetkey=1-66-201611-1
http://www.gentoo.org/security/en/glsa/glsa-200409-12.xml Patch Vendor Advisory
http://www.securityfocus.com/bid/11084 Patch
http://www.vuxml.org/freebsd/ba005226-fb5b-11d8-9837-000c41e2cdad.html Vendor Advisory
https://exchange.xforce.ibmcloud.com/vulnerabilities/17183

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:enlightenment:imlib:1.9:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib:1.9.1:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib:1.9.2:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib:1.9.3:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib:1.9.4:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib:1.9.5:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib:1.9.6:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib:1.9.7:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib:1.9.8:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib:1.9.9:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib:1.9.10:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib:1.9.11:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib:1.9.12:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib:1.9.13:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib:1.9.14:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib2:1.0:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib2:1.0.1:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib2:1.0.2:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib2:1.0.3:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib2:1.0.4:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib2:1.0.5:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib2:1.1:*:*:*:*:*:*:*
cpe:2.3:a:enlightenment:imlib2:1.1.1:*:*:*:*:*:*:*
cpe:2.3:a:imagemagick:imagemagick:5.3.3:*:*:*:*:*:*:*
cpe:2.3:a:imagemagick:imagemagick:5.4.3:*:*:*:*:*:*:*
cpe:2.3:a:imagemagick:imagemagick:5.4.4.5:*:*:*:*:*:*:*
cpe:2.3:a:imagemagick:imagemagick:5.4.7:*:*:*:*:*:*:*
cpe:2.3:a:imagemagick:imagemagick:5.4.8:*:*:*:*:*:*:*
cpe:2.3:a:imagemagick:imagemagick:5.4.8.2.1.1.0:*:*:*:*:*:*:*
cpe:2.3:a:imagemagick:imagemagick:5.5.3.2.1.2.0:*:*:*:*:*:*:*
cpe:2.3:a:imagemagick:imagemagick:5.5.6.0_2003-04-09:*:*:*:*:*:*:*
cpe:2.3:a:imagemagick:imagemagick:5.5.7:*:*:*:*:*:*:*
cpe:2.3:a:imagemagick:imagemagick:6.0.2:*:*:*:*:*:*:*
cpe:2.3:a:sun:java_desktop_system:2.0:*:*:*:*:*:*:*
cpe:2.3:a:sun:java_desktop_system:2003:*:*:*:*:*:*:*
cpe:2.3:o:conectiva:linux:9.0:*:*:*:*:*:*:*
cpe:2.3:o:conectiva:linux:10.0:*:*:*:*:*:*:*
Configuration 2
OR
cpe:2.3:o:mandrakesoft:mandrake_linux:9.2:*:*:*:*:*:*:*
cpe:2.3:o:mandrakesoft:mandrake_linux:9.2:*:amd64:*:*:*:*:*
cpe:2.3:o:mandrakesoft:mandrake_linux:10.0:*:*:*:*:*:*:*
cpe:2.3:o:mandrakesoft:mandrake_linux:10.0:*:amd64:*:*:*:*:*
cpe:2.3:o:mandrakesoft:mandrake_linux_corporate_server:2.1:*:*:*:*:*:*:*
cpe:2.3:o:mandrakesoft:mandrake_linux_corporate_server:2.1:*:x86_64:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux:2.1:*:advanced_server:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux:2.1:*:advanced_server_ia64:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux:2.1:*:enterprise_server:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux:2.1:*:enterprise_server_ia64:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux:2.1:*:workstation:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux:2.1:*:workstation_ia64:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux:3.0:*:advanced_servers:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux:3.0:*:enterprise_server:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux:3.0:*:workstation:*:*:*:*:*
cpe:2.3:o:redhat:enterprise_linux_desktop:3.0:*:*:*:*:*:*:*
cpe:2.3:o:redhat:fedora_core:core_1.0:*:*:*:*:*:*:*
cpe:2.3:o:redhat:fedora_core:core_2.0:*:*:*:*:*:*:*
cpe:2.3:o:redhat:fedora_core:core_3.0:*:*:*:*:*:*:*
cpe:2.3:o:redhat:linux_advanced_workstation:2.1:*:ia64:*:*:*:*:*
cpe:2.3:o:redhat:linux_advanced_workstation:2.1:*:itanium_processor:*:*:*:*:*
cpe:2.3:o:suse:suse_linux:8.0:*:*:*:*:*:*:*
cpe:2.3:o:suse:suse_linux:8.0:*:i386:*:*:*:*:*
cpe:2.3:o:suse:suse_linux:8.1:*:*:*:*:*:*:*
cpe:2.3:o:suse:suse_linux:8.2:*:*:*:*:*:*:*
cpe:2.3:o:suse:suse_linux:9.0:*:*:*:*:*:*:*
cpe:2.3:o:suse:suse_linux:9.0:*:x86_64:*:*:*:*:*
cpe:2.3:o:suse:suse_linux:9.1:*:*:*:*:*:*:*
cpe:2.3:o:suse:suse_linux:9.2:*:*:*:*:*:*:*
cpe:2.3:o:turbolinux:turbolinux_desktop:10.0:*:*:*:*:*:*:*
cpe:2.3:o:turbolinux:turbolinux_server:7.0:*:*:*:*:*:*:*
cpe:2.3:o:turbolinux:turbolinux_server:8.0:*:*:*:*:*:*:*
cpe:2.3:o:turbolinux:turbolinux_workstation:7.0:*:*:*:*:*:*:*
cpe:2.3:o:turbolinux:turbolinux_workstation:8.0:*:*:*:*:*:*:*
cpe:2.3:o:ubuntu:ubuntu_linux:4.1:*:ia64:*:*:*:*:*
cpe:2.3:o:ubuntu:ubuntu_linux:4.1:*:ppc:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2004-0802
NVD Published Date:
12/31/2004
NVD Last Modified:
07/10/2017