National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2004-2763 Detail

Description

The default configuration of Sun ONE/iPlanet Web Server 4.1 SP1 through SP12 and 6.0 SP1 through SP5 responds to the HTTP TRACE request, which can allow remote attackers to steal information using cross-site tracing (XST) attacks in applications that are vulnerable to cross-site scripting.

Source:  MITRE
Description Last Modified:  06/01/2009

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 5.8 MEDIUM
Vector: (AV:N/AC:M/Au:N/C:P/I:P/A:N) (V2 legend)
Impact Subscore: 4.9
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): None
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized disclosure of information
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://archive.cert.uni-stuttgart.de/uniras/2004/02/msg00007.html
http://www.cgisecurity.com/whitehat-mirror/WH-WhitePaper_XST_ebook.pdf Exploit
http://www.kb.cert.org/vuls/id/867593 US Government Resource

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.3

Configuration 1
OR
cpe:/a:sun:iplanet_web_server:4.1:sp1
cpe:/a:sun:iplanet_web_server:4.1:sp1:enterprise
cpe:/a:sun:iplanet_web_server:4.1:sp10
cpe:/a:sun:iplanet_web_server:4.1:sp10:enterprise
cpe:/a:sun:iplanet_web_server:4.1:sp11
cpe:/a:sun:iplanet_web_server:4.1:sp11:enterprise
cpe:/a:sun:iplanet_web_server:4.1:sp12
cpe:/a:sun:iplanet_web_server:4.1:sp12:enterprise
cpe:/a:sun:iplanet_web_server:4.1:sp2
cpe:/a:sun:iplanet_web_server:4.1:sp2:enterprise
cpe:/a:sun:iplanet_web_server:4.1:sp3
cpe:/a:sun:iplanet_web_server:4.1:sp3:enterprise
cpe:/a:sun:iplanet_web_server:4.1:sp4
cpe:/a:sun:iplanet_web_server:4.1:sp4:enterprise
cpe:/a:sun:iplanet_web_server:4.1:sp5
cpe:/a:sun:iplanet_web_server:4.1:sp5:enterprise
cpe:/a:sun:iplanet_web_server:4.1:sp6
cpe:/a:sun:iplanet_web_server:4.1:sp6:enterprise
cpe:/a:sun:iplanet_web_server:4.1:sp7
cpe:/a:sun:iplanet_web_server:4.1:sp7:enterprise
cpe:/a:sun:iplanet_web_server:4.1:sp8
cpe:/a:sun:iplanet_web_server:4.1:sp8:enterprise
cpe:/a:sun:iplanet_web_server:4.1:sp9
cpe:/a:sun:iplanet_web_server:4.1:sp9:enterprise
cpe:/a:sun:iplanet_web_server:6.0:sp1
cpe:/a:sun:iplanet_web_server:6.0:sp2
cpe:/a:sun:iplanet_web_server:6.0:sp3
cpe:/a:sun:iplanet_web_server:6.0:sp4
cpe:/a:sun:iplanet_web_server:6.0:sp5
cpe:/a:sun:one_web_server:4.1
cpe:/a:sun:one_web_server:4.1:sp1
cpe:/a:sun:one_web_server:4.1:sp10
cpe:/a:sun:one_web_server:4.1:sp11
cpe:/a:sun:one_web_server:4.1:sp12
cpe:/a:sun:one_web_server:4.1:sp2
cpe:/a:sun:one_web_server:4.1:sp3
cpe:/a:sun:one_web_server:4.1:sp4
cpe:/a:sun:one_web_server:4.1:sp5
cpe:/a:sun:one_web_server:4.1:sp6
cpe:/a:sun:one_web_server:4.1:sp7
cpe:/a:sun:one_web_server:4.1:sp8
cpe:/a:sun:one_web_server:4.1:sp9
cpe:/a:sun:one_web_server:6.0:sp3
cpe:/a:sun:one_web_server:6.0:sp4
cpe:/a:sun:one_web_server:6.0:sp5
cpe:/a:sun:one_web_server:6.1:sp1
cpe:/a:sun:one_web_server:6.1:sp2

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

1 change record found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2004-2763
NVD Published Date:
06/01/2009
NVD Last Modified:
06/02/2009