National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2005-0245 Detail

Description

Buffer overflow in gram.y for PostgreSQL 8.0.0 and earlier may allow attackers to execute arbitrary code via a large number of arguments to a refcursor function (gram.y), which leads to a heap-based buffer overflow, a different vulnerability than CVE-2005-0247.

Source:  MITRE
Description Last Modified:  02/01/2005

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 7.5 HIGH
Vector: (AV:N/AC:L/Au:N/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Provides unauthorized access
Allows unauthorized disclosure of information
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://archives.postgresql.org/pgsql-committers/2005-01/msg00298.php Vendor Advisory
http://archives.postgresql.org/pgsql-committers/2005-02/msg00049.php Vendor Advisory
http://archives.postgresql.org/pgsql-patches/2005-01/msg00216.php Exploit Vendor Advisory
http://marc.info/?l=bugtraq&m=110806034116082&w=2
http://www.debian.org/security/2005/dsa-683 Exploit Vendor Advisory
http://www.mandriva.com/security/advisories?name=MDKSA-2005:040
http://www.novell.com/linux/security/advisories/2005_36_sudo.html
http://www.redhat.com/support/errata/RHSA-2005-138.html Patch Vendor Advisory
http://www.redhat.com/support/errata/RHSA-2005-150.html Patch Vendor Advisory
http://www.securityfocus.com/bid/12417
https://exchange.xforce.ibmcloud.com/vulnerabilities/19188
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10175

References to Check Content

Identifier:
oval:org.mitre.oval:def:10175
Check System:
http://oval.mitre.org/XMLSchema/oval-definitions-5
Hyperlink:
http://oval.mitre.org/repository/data/DownloadDefinition?id=oval:org.mitre.oval:def:10175

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:postgresql:postgresql:7.2:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.2.1:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.2.2:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.2.3:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.2.4:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.2.5:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.2.6:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.2.7:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.3:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.3.1:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.3.2:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.3.3:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.3.4:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.3.5:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.3.6:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.3.7:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.3.8:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.3.9:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.4:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.4.1:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.4.2:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.4.3:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.4.4:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.4.5:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.4.6:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:7.4.7:*:*:*:*:*:*:*
cpe:2.3:a:postgresql:postgresql:8.0:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

5 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2005-0245
NVD Published Date:
02/01/2005
NVD Last Modified:
10/10/2017