National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2005-0467 Detail

Description

Multiple integer overflows in the (1) sftp_pkt_getstring and (2) fxp_readdir_recv functions in the PSFTP and PSCP clients for PuTTY 0.56, and possibly earlier versions, allow remote malicious web sites to execute arbitrary code via SFTP responses that corrupt the heap after insufficient memory has been allocated.

Source:  MITRE
Description Last Modified:  02/21/2005

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 7.5 HIGH
Vector: (AV:N/AC:L/Au:N/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Provides user account access
Allows unauthorized disclosure of information
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/vuln-sftp-readdir.html Vendor Advisory
http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/vuln-sftp-string.html Vendor Advisory
http://www.gentoo.org/security/en/glsa/glsa-200502-28.xml Patch Vendor Advisory
http://www.idefense.com/application/poi/display?id=201&type=vulnerabilities Patch Vendor Advisory
http://www-1.ibm.com/support/docview.wss?uid=ssg1S1002414
http://www-1.ibm.com/support/docview.wss?uid=ssg1S1002416
https://exchange.xforce.ibmcloud.com/vulnerabilities/19403

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:putty:putty:*:*:*:*:*:*:*:*    versions up to (including) 0.56

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2005-0467
NVD Published Date:
02/21/2005
NVD Last Modified:
07/10/2017