National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2005-3300 Detail

Description

The register_globals emulation layer in grab_globals.php for phpMyAdmin before 2.6.4-pl3 does not perform safety checks on values in the _FILES array for uploaded files, which allows remote attackers to include arbitrary files by using direct requests to library scripts that do not use grab_globals.php, then modifying certain configuration values for the theme.

Source:  MITRE
Description Last Modified:  10/23/2005

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 5.0 MEDIUM
Vector: (AV:N/AC:L/Au:N/C:N/I:P/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): None
Integrity (I): Partial
Availability (A): None
Additional Information:
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://archives.neohapsis.com/archives/fulldisclosure/2005-10/0478.
http://marc.info/?l=bugtraq&m=113017591414699&w=2
http://securitytracker.com/id?1015091
http://www.debian.org/security/2005/dsa-880
http://www.gentoo.org/security/en/glsa/glsa-200510-21.xml
http://www.hardened-php.net/advisory_162005.73.html Patch Vendor Advisory
http://www.novell.com/linux/security/advisories/2005_28_sr.html
http://www.novell.com/linux/security/advisories/2005_66_phpmyadmin.html
http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2005-5 Patch Vendor Advisory
http://www.securityfocus.com/bid/15169
https://exchange.xforce.ibmcloud.com/vulnerabilities/22835

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:phpmyadmin:phpmyadmin:2.6.4_pl3:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2005-3300
NVD Published Date:
10/23/2005
NVD Last Modified:
07/10/2017