National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2006-2109 Detail

Description

Cross-site scripting (XSS) vulnerability in the parse_query_str function in include/print.php in JSBoard 2.0.10 and 2.0.11, and possibly other versions before 2.0.12, allows remote attackers to inject arbitrary web script or HTML via parameters that are set as global variables within the program, as demonstrated using the table parameter to login.php.

Source:  MITRE
Description Last Modified:  05/02/2006

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 6.8 MEDIUM
Vector: (AV:N/AC:M/Au:N/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Provides unauthorized access
Allows unauthorized disclosure of information
Allows disruption of service

Evaluator Solution

This vulnerability is addressed in the following product release: JSBoard, JSBoard, 2.0.12

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://www.securityfocus.com/archive/1/432714/100/0/threaded
http://www.securityfocus.com/bid/17778
http://www.vupen.com/english/advisories/2006/1636
https://exchange.xforce.ibmcloud.com/vulnerabilities/26211
https://www.klink.name/security/aklink-sa-2006-001-jsboard-xss.txt Exploit Patch Vendor Advisory

Technical Details

Vulnerability Type (View All)

Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2006-2109
NVD Published Date:
05/02/2006
NVD Last Modified:
10/18/2018