National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2006-2471 Detail

Current Description

Multiple vulnerabilities in BEA WebLogic Server 8.1 through SP4, 7.0 through SP6, and 6.1 through SP7 leak sensitive information to remote attackers, including (1) DNS and IP addresses to address to T3 clients, (2) internal sensitive information using GetIORServlet, (3) certain "server details" in exceptions when invalid XML is provided, and (4) a stack trace in a SOAP fault.

Source:  MITRE
View Analysis Description

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 5.0 MEDIUM
Vector: (AV:N/AC:L/Au:N/C:P/I:N/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): None
Availability (A): None
Additional Information:
Allows unauthorized disclosure of information

Evaluator Solution

This vulnerability is addressed in the following product releases: BEA Systems, Weblogic Server, 8.1 SP 5 BEA Systems, Weblogic Express, 8.1 SP 5 BEA Systems, Weblogic Server, 7.0 SP 7 BEA Systems, Weblogic Express, 7.0 SP 7 BEA Systems, Weblogic Server, 6.1 SP 8 BEA Systems, Weblogic Express, 6.1 SP 8

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://dev2dev.bea.com/pub/advisory/187 Patch Vendor Advisory
http://securitytracker.com/id?1016096
http://www.vupen.com/english/advisories/2006/1828
https://exchange.xforce.ibmcloud.com/vulnerabilities/26465

Technical Details

Vulnerability Type (View All)

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:bea:weblogic_server:6.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:6.1:*:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:6.1:sp1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:6.1:sp1:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:6.1:sp2:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:6.1:sp2:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:6.1:sp3:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:6.1:sp3:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:6.1:sp4:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:6.1:sp4:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:6.1:sp5:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:6.1:sp5:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:6.1:sp6:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:6.1:sp6:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:6.1:sp7:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:6.1:sp7:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:7.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:7.0:*:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:7.0:sp1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:7.0:sp1:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:7.0:sp2:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:7.0:sp2:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:7.0:sp3:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:7.0:sp3:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:7.0:sp4:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:7.0:sp4:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:7.0:sp5:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:7.0:sp5:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:7.0:sp6:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:7.0:sp6:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:8.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:8.1:*:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:8.1:sp1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:8.1:sp1:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:8.1:sp2:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:8.1:sp2:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:8.1:sp3:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:8.1:sp3:express:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:8.1:sp4:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:bea:weblogic_server:8.1:sp4:express:*:*:*:*:*
     Show Matching CPE(s)


Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2006-2471
NVD Published Date:
05/19/2006
NVD Last Modified:
07/19/2017