National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2006-2788 Detail

Current Description

Double free vulnerability in the getRawDER function for nsIX509Cert in Firefox allows remote attackers to cause a denial of service (hang) and possibly execute arbitrary code via certain Javascript code.

Source:  MITRE
View Analysis Description

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 7.5 HIGH
Vector: (AV:N/AC:L/Au:N/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Provides user account access
Allows unauthorized disclosure of information
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://rhn.redhat.com/errata/RHSA-2006-0609.html
http://www.debian.org/security/2006/dsa-1192
http://www.debian.org/security/2006/dsa-1210
http://www.mandriva.com/security/advisories?name=MDKSA-2006:143
http://www.mandriva.com/security/advisories?name=MDKSA-2006:145
http://www.redhat.com/support/errata/RHSA-2006-0578.html
http://www.redhat.com/support/errata/RHSA-2006-0594.html
http://www.redhat.com/support/errata/RHSA-2006-0610.html
http://www.redhat.com/support/errata/RHSA-2006-0611.html
http://www.ubuntu.com/usn/usn-361-1
http://www.us.debian.org/security/2006/dsa-1191
https://bugzilla.mozilla.org/show_bug.cgi?id=321598 Exploit Patch
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11065
https://usn.ubuntu.com/296-1/

Technical Details

Vulnerability Type (View All)

  • Improper Restriction of Operations within the Bounds of a Memory Buffer (CWE-119)

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:mozilla:firefox:0.8:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:0.9:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:0.9:rc:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:0.9.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:0.9.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:0.9.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:0.10:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:0.10.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:1.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:1.0.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:1.0.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:1.0.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:1.0.4:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:1.0.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:1.0.6:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:1.0.6:*:linux:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:1.0.7:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:1.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:1.5:beta1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:1.5:beta2:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:1.5.0.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:1.5.0.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:1.5.0.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox:preview_release:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2006-2788
NVD Published Date:
06/02/2006
NVD Last Modified:
10/03/2018