National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2006-4790 Detail

Description

verify.c in GnuTLS before 1.4.4, when using an RSA key with exponent 3, does not properly handle excess data in the digestAlgorithm.parameters field when generating a hash, which allows remote attackers to forge a PKCS #1 v1.5 signature that is signed by that RSA key and prevents GnuTLS from correctly verifying X.509 and other certificates that use PKCS, a variant of CVE-2006-4339.

Source:  MITRE
Description Last Modified:  09/14/2006

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 5.0 MEDIUM
Vector: (AV:N/AC:L/Au:N/C:N/I:P/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): None
Integrity (I): Partial
Availability (A): None
Additional Information:
Allows unauthorized modification

Vendor Statements (disclaimer)

Official Statement from Red Hat (03/14/2007)

Red Hat Enterprise Linux 5 is not vulnerable to this issue as it contains a backported patch.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.gnupg.org/pipermail/gnutls-dev/2006-September/001205.html
http://lists.gnupg.org/pipermail/gnutls-dev/2006-September/001212.html
http://security.gentoo.org/glsa/glsa-200609-15.xml
http://securitytracker.com/id?1016844
http://sunsolve.sun.com/search/document.do?assetkey=1-26-102648-1
http://sunsolve.sun.com/search/document.do?assetkey=1-26-102970-1
http://support.avaya.com/elmodocs2/security/ASA-2006-250.htm
http://www.debian.org/security/2006/dsa-1182
http://www.gnu.org/software/gnutls/security.html Patch
http://www.mandriva.com/security/advisories?name=MDKSA-2006:166
http://www.novell.com/linux/security/advisories/2006_23_sr.html
http://www.novell.com/linux/security/advisories/2007_10_ibmjava.html
http://www.redhat.com/support/errata/RHSA-2006-0680.html Patch Vendor Advisory
http://www.securityfocus.com/bid/20027
http://www.ubuntu.com/usn/usn-348-1
http://www.vupen.com/english/advisories/2006/3635
http://www.vupen.com/english/advisories/2006/3899
http://www.vupen.com/english/advisories/2007/2289
https://exchange.xforce.ibmcloud.com/vulnerabilities/28953
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9937

References to Check Content

Identifier:
oval:org.mitre.oval:def:9937
Check System:
http://oval.mitre.org/XMLSchema/oval-definitions-5
Hyperlink:
http://oval.mitre.org/repository/data/DownloadDefinition?id=oval:org.mitre.oval:def:9937

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:gnu:gnutls:1.0.17:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.0.18:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.0.19:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.0.20:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.0.21:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.0.22:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.0.23:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.0.24:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.0.25:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.1.14:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.1.15:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.1.16:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.1.17:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.1.18:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.1.19:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.1.20:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.1.21:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.1.22:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.1.23:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.2.0:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.2.1:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.2.2:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.2.3:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.2.4:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.2.5:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.2.6:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.2.7:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.2.8:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.2.8.1a1:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.2.9:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.2.10:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.2.11:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.3.0:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.3.1:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.3.2:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.3.3:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.3.4:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.3.5:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.4.0:*:*:*:*:*:*:*
cpe:2.3:a:gnu:gnutls:1.4.1:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2006-4790
NVD Published Date:
09/14/2006
NVD Last Modified:
10/10/2017