National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2007-0240 Detail

Description

Cross-site scripting (XSS) vulnerability in Zope 2.10.2 and earlier allows remote attackers to inject arbitrary web script or HTML via unspecified vectors in a HTTP GET request.

Source:  MITRE
Description Last Modified:  03/22/2007

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 4.3 MEDIUM
Vector: (AV:N/AC:M/Au:N/C:N/I:P/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): None
Integrity (I): Partial
Availability (A): None
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized modification

Vendor Statements (disclaimer)

Official Statement from Red Hat (04/02/2007)

Not vulnerable. This issue did not affect Zope included within the conga package shipped with Red Hat Enterprise Linux 5.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.suse.com/archive/suse-security-announce/2007-May/0005.html
http://www.debian.org/security/2007/dsa-1275
http://www.securityfocus.com/bid/23084
http://www.vupen.com/english/advisories/2007/1041
http://www.zope.org/Products/Zope/Hotfix-2007-03-20/announcement/view Patch Vendor Advisory
https://exchange.xforce.ibmcloud.com/vulnerabilities/33187

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:zope:zope:*:*:*:*:*:*:*:*    versions up to (including) 2.10.2

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2007-0240
NVD Published Date:
03/22/2007
NVD Last Modified:
07/28/2017