National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2007-0774 Detail

Current Description

Stack-based buffer overflow in the map_uri_to_worker function (native/common/jk_uri_worker_map.c) in mod_jk.so for Apache Tomcat JK Web Server Connector 1.2.19 and 1.2.20, as used in Tomcat 4.1.34 and 5.5.20, allows remote attackers to execute arbitrary code via a long URL that triggers the overflow in a URI worker map routine.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: N/A
NVD score not yet provided.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01178795
http://securitytracker.com/id?1017719
http://tomcat.apache.org/connectors-doc/miscellaneous/changelog.html Patch
http://tomcat.apache.org/security-jk.html
http://www.cisco.com/en/US/products/products_security_advisory09186a008093f040.shtml
http://www.gentoo.org/security/en/glsa/glsa-200703-16.xml
http://www.redhat.com/support/errata/RHSA-2007-0096.html
http://www.securityfocus.com/archive/1/461734/100/0/threaded
http://www.securityfocus.com/bid/22791
http://www.vupen.com/english/advisories/2007/0809
http://www.vupen.com/english/advisories/2007/3386
http://www.vupen.com/english/advisories/2008/0331
http://www.zerodayinitiative.com/advisories/ZDI-07-008.html Vendor Advisory
https://exchange.xforce.ibmcloud.com/vulnerabilities/32794
https://lists.apache.org/thread.html/277d42b48b6e9aef50949c0dcc79ce21693091d73da246b3c1981925@%3Cdev.tomcat.apache.org%3E
https://lists.apache.org/thread.html/5b7a23e245c93235c503900da854a143596d901bf1a1f67e851a5de4@%3Cdev.tomcat.apache.org%3E
https://lists.apache.org/thread.html/8d2a579bbd977c225c70cb23b0ec54865fb0dab5da3eff1e060c9935@%3Cdev.tomcat.apache.org%3E
https://lists.apache.org/thread.html/ba661b0edd913b39ff129a32d855620dd861883ade05fd88a8ce517d@%3Cdev.tomcat.apache.org%3E
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A5513

Weakness Enumeration

CWE-ID CWE Name Source
NVD-CWE-Other Other NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:apache:tomcat_jk_web_server_connector:1.2.19:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:apache:tomcat_jk_web_server_connector:1.2.20:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

8 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2007-0774
NVD Published Date:
03/04/2007
NVD Last Modified:
04/15/2019