National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2007-1366 Detail

Description

QEMU 0.8.2 allows local users to crash a virtual machine via the divisor operand to the aam instruction, as demonstrated by "aam 0x0," which triggers a divide-by-zero error.

Source:  MITRE      Last Modified:  05/02/2007

Quick Info

CVE Dictionary Entry:
CVE-2007-1366
Original release date:
05/02/2007
Last revised:
07/28/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
4.9 MEDIUM
Vector:
(AV:L/AC:L/Au:N/C:N/I:N/A:C) (legend)
Impact Subscore:
6.9
Exploitability Subscore:
3.9
CVSS Version 2 Metrics:
Access Vector:
Locally exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows disruption of service

Vendor Statements (disclaimer)

Official Statement from Red Hat (09/24/2007)

Not vulnerable. This issue did not affect Xen as shipped with Red Hat Enterprise Linux 5.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://lists.gnu.org/archive/html/qemu-devel/2007-04/msg00650.html External Source MLIST [Qemu-devel] 20070428 Qemu crashes on AAM 0
http://lists.gnu.org/archive/html/qemu-devel/2007-04/msg00651.html External Source MLIST [Qemu-devel] 20070429 Re: Qemu crashes on AAM 0
http://taviso.decsystem.org/virtsec.pdf External Source MISC http://taviso.decsystem.org/virtsec.pdf
http://www.debian.org/security/2007/dsa-1284 External Source DEBIAN DSA-1284
http://www.mandriva.com/security/advisories?name=MDVSA-2008:162 External Source MANDRIVA MDVSA-2008:162
http://www.securityfocus.com/bid/23731 External Source BID 23731
http://www.vupen.com/english/advisories/2007/1597 External Source VUPEN ADV-2007-1597
https://exchange.xforce.ibmcloud.com/vulnerabilities/34046 External Source XF qemu-aam-dos(34046)

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:fabrice_bellard:qemu:0.8.2:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 2 change records found - show changes