National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2007-1401 Detail

Description

Buffer overflow in the crack extension (CrackLib), as bundled with PHP 4.4.6 and other versions before 5.0.0, might allow local users to gain privileges via a long argument to the crack_opendict function.

Source:  MITRE
Description Last Modified:  03/10/2007

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 6.9 MEDIUM
Vector: (AV:L/AC:M/Au:N/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 3.4


Access Vector (AV): Local
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Provides administrator access
Allows unauthorized disclosure of information
Allows disruption of service

Vendor Statements (disclaimer)

Official Statement from Red Hat (03/19/2007)

Not vulnerable. PHP as shipped with Red Hat Enterprise Linux 2.1, 3, 4, and 5 does not include Cracklib support.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://retrogod.altervista.org/php_446_crack_opendict_local_bof.html Exploit
http://securityreason.com/securityalert/2405
http://www.securityfocus.com/archive/1/archive/1/462226/100/0/threaded Exploit
https://www.exploit-db.com/exploits/3431

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:php:php:4.4.6:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2007-1401
NVD Published Date:
03/10/2007
NVD Last Modified:
10/10/2017