National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2007-2297 Detail

Current Description

The SIP channel driver (chan_sip) in Asterisk before 1.2.18 and 1.4.x before 1.4.3 does not properly parse SIP UDP packets that do not contain a valid response code, which allows remote attackers to cause a denial of service (crash).

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: N/A
NVD score not yet provided.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://bugs.digium.com/view.php?id=9313
http://securityreason.com/securityalert/2644
http://www.asterisk.org/files/ASA-2007-011.pdf
http://www.debian.org/security/2007/dsa-1358
http://www.novell.com/linux/security/advisories/2007_34_asterisk.html
http://www.securityfocus.com/archive/1/466882/100/0/threaded
http://www.securityfocus.com/bid/24359
http://www.securitytracker.com/id?1017954 Patch
https://exchange.xforce.ibmcloud.com/vulnerabilities/33892

Weakness Enumeration

CWE-ID CWE Name Source
NVD-CWE-Other Other NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:asterisk:asterisk:1.2.0_beta1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:asterisk:asterisk:1.2.0_beta2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:asterisk:asterisk:1.2.10:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:asterisk:asterisk:1.2.11:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:asterisk:asterisk:1.2.12:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:asterisk:asterisk:1.2.13:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:asterisk:asterisk:1.2.14:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:asterisk:asterisk:1.2.15:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:asterisk:asterisk:1.2.16:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:asterisk:asterisk:1.2.17:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:asterisk:asterisk:1.4.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:asterisk:asterisk:1.4.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:asterisk:asterisk:1.4_beta:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2007-2297
NVD Published Date:
04/26/2007
NVD Last Modified:
10/16/2018