National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2007-4784 Detail

Description

The setlocale function in PHP before 5.2.4 allows context-dependent attackers to cause a denial of service (application crash) via a long string in the locale parameter. NOTE: this might not be a vulnerability in most web server environments that support multiple threads, unless this issue can be demonstrated for code execution.

Source:  MITRE      Last Modified:  09/10/2007

Quick Info

CVE Dictionary Entry:
CVE-2007-4784
Original release date:
09/10/2007
Last revised:
07/28/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
5.0 MEDIUM
Vector:
(AV:N/AC:L/Au:N/C:N/I:N/A:P) (legend)
Impact Subscore:
2.9
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows disruption of service

Vendor Statements (disclaimer)

Official Statement from Red Hat (09/12/2007)

We do not consider this to be a security issue. For more information please see http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=169857#c1 and http://www.php.net/security-note.php

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://lists.opensuse.org/opensuse-security-announce/2008-01/msg00006.html External Source SUSE SUSE-SA:2008:004
http://securityreason.com/securityalert/3114 External Source SREASON 3114
http://www.gentoo.org/security/en/glsa/glsa-200710-02.xml External Source GENTOO GLSA-200710-02
http://www.securityfocus.com/archive/1/archive/1/478627/100/0/threaded External Source BUGTRAQ 20070904 PHP < 5.2.4 setlocale() denial of service
https://exchange.xforce.ibmcloud.com/vulnerabilities/36458 External Source XF php-setlocale-dos(36458)

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.2.3

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 2 change records found - show changes