CVE-2007-6015 Detail

Current Description

Stack-based buffer overflow in the send_mailslot function in nmbd in Samba 3.0.0 through 3.0.27a, when the "domain logons" option is enabled, allows remote attackers to execute arbitrary code via a GETDC mailslot request composed of a long GETDC string following an offset username in a SAMLOGON logon request.


View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score:  N/A
NVD score not yet provided.


NVD Analysts use publicly available information to associate vector strings and CVSS scores. We also display any CVSS information provided within the CVE List from the CNA.

Note: NVD Analysts have not published a CVSS score for this CVE at this time. NVD Analysts use publicly available information at the time of analysis to associate CVSS vector strings.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://bugs.gentoo.org/show_bug.cgi?id=200773
http://docs.info.apple.com/article.html?artnum=307430
http://lists.apple.com/archives/security-announce/2008/Feb/msg00002.html
http://lists.vmware.com/pipermail/security-announce/2008/000005.html
http://marc.info/?l=bugtraq&m=120524782005154&w=2
http://security.gentoo.org/glsa/glsa-200712-10.xml
http://securityreason.com/securityalert/3438
http://slackware.com/security/viewer.php?l=slackware-security&y=2007&m=slackware-security.451554
http://sunsolve.sun.com/search/document.do?assetkey=1-26-238251-1
http://sunsolve.sun.com/search/document.do?assetkey=1-77-1019295.1-1
http://support.avaya.com/elmodocs2/security/ASA-2007-520.htm
http://www.debian.org/security/2007/dsa-1427
http://www.kb.cert.org/vuls/id/438395 US Government Resource 
http://www.mandriva.com/security/advisories?name=MDKSA-2007:244
http://www.novell.com/linux/security/advisories/2007_68_samba.html
http://www.redhat.com/support/errata/RHSA-2007-1114.html Patch 
http://www.redhat.com/support/errata/RHSA-2007-1117.html
http://www.samba.org/samba/security/CVE-2007-6015.html Patch 
http://www.securityfocus.com/archive/1/484818/100/0/threaded
http://www.securityfocus.com/archive/1/484825/100/0/threaded
http://www.securityfocus.com/archive/1/484827/100/0/threaded
http://www.securityfocus.com/archive/1/485144/100/0/threaded
http://www.securityfocus.com/archive/1/488457/100/0/threaded
http://www.securityfocus.com/bid/26791
http://www.securitytracker.com/id?1019065
http://www.ubuntu.com/usn/usn-556-1
http://www.us-cert.gov/cas/techalerts/TA08-043B.html US Government Resource 
http://www.vupen.com/english/advisories/2007/4153
http://www.vupen.com/english/advisories/2008/0495/references
http://www.vupen.com/english/advisories/2008/0637
http://www.vupen.com/english/advisories/2008/0859/references
http://www.vupen.com/english/advisories/2008/1712/references
http://www.vupen.com/english/advisories/2008/1908
http://www11.itrc.hp.com/service/cki/docDisplay.do?docId=emr_na-c01475657
https://exchange.xforce.ibmcloud.com/vulnerabilities/38965
https://issues.rpath.com/browse/RPL-1976
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11572
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A5605
https://www.redhat.com/archives/fedora-package-announce/2007-December/msg00304.html
https://www.redhat.com/archives/fedora-package-announce/2007-December/msg00308.html

Weakness Enumeration

CWE-ID CWE Name Source
CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer cwe source acceptance level NIST  

Known Affected Software Configurations Switch to CPE 2.2

CPEs loading, please wait.

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

5 change records found show changes

Quick Info

CVE Dictionary Entry:
CVE-2007-6015
NVD Published Date:
12/13/2007
NVD Last Modified:
10/30/2018
Source:
MITRE