National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2008-0145 Detail

Description

Unspecified vulnerability in glob in PHP before 4.4.8, when open_basedir is enabled, has unknown impact and attack vectors. NOTE: this issue reportedly exists because of a regression related to CVE-2007-4663.

Source:  MITRE      Last Modified:  01/08/2008

Quick Info

CVE Dictionary Entry:
CVE-2008-0145
Original release date:
01/08/2008
Last revised:
08/07/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
7.5 HIGH
Vector:
(AV:N/AC:L/Au:N/C:P/I:P/A:P) (legend)
Impact Subscore:
6.4
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service

Vendor Statements (disclaimer)

Official Statement from Red Hat (01/10/2008)

Red Hat does not consider this to be a security issue. Regression introduced break glob() functionality, but does not bypass security restrictions. Furthermore, "open_basedir" bypass issues are not treated as security sensitive as described at https://bugzilla.redhat.com/show_bug.cgi?id=169857#c1 and http://www.php.net/security-note.php

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://bugs.php.net/bug.php?id=41655 Exploit External Source CONFIRM http://bugs.php.net/bug.php?id=41655
http://slackware.com/security/viewer.php?l=slackware-security&y=2008&m=slackware-security.335136 External Source SLACKWARE SSA:2008-045-03
http://www.php.net/ChangeLog-4.php External Source CONFIRM http://www.php.net/ChangeLog-4.php
http://www.php.net/releases/4_4_8.php External Source CONFIRM http://www.php.net/releases/4_4_8.php
http://www.vupen.com/english/advisories/2008/0059 External Source VUPEN ADV-2008-0059
https://exchange.xforce.ibmcloud.com/vulnerabilities/39401 External Source XF php-glob-openbasedir-security-bypass(39401)

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.4.7

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 2 change records found - show changes