National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2008-1456 Detail

Current Description

Array index vulnerability in the Event System in Microsoft Windows 2000 SP4, XP SP2 and SP3, Server 2003 SP1 and SP2, Vista Gold and SP1, and Server 2008 allows remote authenticated users to execute arbitrary code via a crafted event subscription request that is used to access an array of function pointers.

Source:  MITRE
View Analysis Description

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 9.0 HIGH
Vector: (AV:N/AC:L/Au:S/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 8.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): Single
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Provides administrator access
Allows unauthorized disclosure of information
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://marc.info/?l=bugtraq&m=121915960406986&w=2
http://www.securityfocus.com/bid/30586
http://www.securitytracker.com/id?1020677
http://www.us-cert.gov/cas/techalerts/TA08-225A.html US Government Resource
http://www.vupen.com/english/advisories/2008/2353
https://docs.microsoft.com/en-us/security-updates/securitybulletins/2008/ms08-049
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A5630

Technical Details

Vulnerability Type (View All)

  • Improper Input Validation (CWE-20)

Known Affected Software Configurations Switch to CPE 2.3

Configuration 1 ( hide )
 cpe:/o:microsoft:windows-nt:2008
     Show Matching CPE(s)
 cpe:/o:microsoft:windows-nt:vista::gold
     Show Matching CPE(s)
 cpe:/o:microsoft:windows-nt:xp:sp3
     Show Matching CPE(s)
 cpe:/o:microsoft:windows_2000::sp4
     Show Matching CPE(s)
 cpe:/o:microsoft:windows_2003_server::sp1
     Show Matching CPE(s)
 cpe:/o:microsoft:windows_2003_server::sp2
     Show Matching CPE(s)
 cpe:/o:microsoft:windows_vista:-:sp1
     Show Matching CPE(s)
 cpe:/o:microsoft:windows_xp::sp2
     Show Matching CPE(s)


Change History

4 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2008-1456
NVD Published Date:
08/13/2008
NVD Last Modified:
10/30/2018