National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2008-2950 Detail

Description

The Page destructor in Page.cc in libpoppler in Poppler 0.8.4 and earlier deletes a pageWidgets object even if it is not initialized by a Page constructor, which allows remote attackers to execute arbitrary code via a crafted PDF document.

Source:  MITRE      Last Modified:  07/07/2008

Quick Info

CVE Dictionary Entry:
CVE-2008-2950
Original release date:
07/07/2008
Last revised:
09/28/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
7.5 HIGH
Vector:
(AV:N/AC:L/Au:N/C:P/I:P/A:P) (legend)
Impact Subscore:
6.4
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Provides unauthorized access, Allows partial confidentiality, integrity, and availability violation; Allows unauthorized disclosure of information; Allows disruption of service

Vendor Statements (disclaimer)

Official Statement from Red Hat (07/08/2008)

Not vulnerable. This issue did not affect the versions of poppler as shipped with Red Hat Enterprise Linux 5, or other PDF parsing applications derived from the xpdf code as shipped in Red Hat Enterprise Linux 2.1, 3, 4, or 5.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://lists.opensuse.org/opensuse-security-announce/2008-07/msg00006.html External Source SUSE SUSE-SR:2008:015
http://security.gentoo.org/glsa/glsa-200807-04.xml External Source GENTOO GLSA-200807-04
http://securityreason.com/securityalert/3977 External Source SREASON 3977
http://wiki.rpath.com/Advisories:rPSA-2008-0223 External Source CONFIRM http://wiki.rpath.com/Advisories:rPSA-2008-0223
http://www.mandriva.com/security/advisories?name=MDVSA-2008:146 External Source MANDRIVA MDVSA-2008:146
http://www.ocert.org/advisories/ocert-2008-007.html External Source MISC http://www.ocert.org/advisories/ocert-2008-007.html
http://www.securityfocus.com/archive/1/archive/1/493980/100/0/threaded External Source BUGTRAQ 20080707 [oCERT-2008-007] libpoppler uninitialized pointer
http://www.securityfocus.com/archive/1/archive/1/494142/100/0/threaded External Source BUGTRAQ 20080709 rPSA-2008-0223-1 poppler
http://www.securityfocus.com/bid/30107 External Source BID 30107
http://www.securitytracker.com/id?1020435 External Source SECTRACK 1020435
http://www.ubuntu.com/usn/usn-631-1 External Source UBUNTU USN-631-1
http://www.vupen.com/english/advisories/2008/2024/references External Source VUPEN ADV-2008-2024
https://exchange.xforce.ibmcloud.com/vulnerabilities/43619 External Source XF poppler-page-destructor-code-execution(43619)
https://www.exploit-db.com/exploits/6032 External Source EXPLOIT-DB 6032
https://www.redhat.com/archives/fedora-package-announce/2008-August/msg00161.html External Source FEDORA FEDORA-2008-7104

Technical Details

Vulnerability Type (View All)

Change History 3 change records found - show changes