National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2008-3655 Detail

Current Description

Ruby 1.8.5 and earlier, 1.8.6 through 1.8.6-p286, 1.8.7 through 1.8.7-p71, and 1.9 through r18423 does not properly restrict access to critical variables and methods at various safe levels, which allows context-dependent attackers to bypass intended access restrictions via (1) untrace_var, (2) $PROGRAM_NAME, and (3) syslog at safe level 4, and (4) insecure methods at safe levels 1 through 3.

Source:  MITRE
Description Last Modified:  08/12/2008
View Analysis Description

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 7.5 HIGH
Vector: (AV:N/AC:L/Au:N/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=494401
http://lists.apple.com/archives/security-announce/2009/May/msg00002.html
http://security.gentoo.org/glsa/glsa-200812-17.xml
http://support.apple.com/kb/HT3549
http://support.avaya.com/elmodocs2/security/ASA-2008-424.htm
http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0264
http://www.debian.org/security/2008/dsa-1651 Patch
http://www.debian.org/security/2008/dsa-1652
http://www.redhat.com/support/errata/RHSA-2008-0895.html
http://www.redhat.com/support/errata/RHSA-2008-0897.html
http://www.ruby-lang.org/en/news/2008/08/08/multiple-vulnerabilities-in-ruby/ Exploit
http://www.securityfocus.com/archive/1/495884/100/0/threaded
http://www.securityfocus.com/bid/30644 Exploit Patch
http://www.securitytracker.com/id?1020656
http://www.us-cert.gov/cas/techalerts/TA09-133A.html US Government Resource
http://www.vupen.com/english/advisories/2008/2334 Vendor Advisory
http://www.vupen.com/english/advisories/2009/1297 Patch Vendor Advisory
https://exchange.xforce.ibmcloud.com/vulnerabilities/44369
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11602
https://usn.ubuntu.com/651-1/
https://www.redhat.com/archives/fedora-package-announce/2008-October/msg00259.html
https://www.redhat.com/archives/fedora-package-announce/2008-October/msg00299.html

References to Check Content

Identifier:
oval:org.mitre.oval:def:11602
Check System:
http://oval.mitre.org/XMLSchema/oval-definitions-5
Hyperlink:
http://oval.mitre.org/repository/data/DownloadDefinition?id=oval:org.mitre.oval:def:11602

Technical Details

Vulnerability Type (View All)

  • Permissions, Privileges, and Access Control (CWE-264)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:ruby-lang:ruby:1.6.8:*:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.0:*:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.1:*:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.1:-9:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.2:*:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.2:preview2:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.2:preview3:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.2:preview4:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.3:*:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.3:preview1:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.3:preview2:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.3:preview3:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.4:*:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.4:preview1:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.4:preview2:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.4:preview3:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:*:*:*:*:*:*:*:*    versions up to (including) 1.8.5
cpe:2.3:a:ruby-lang:ruby:1.8.5:p11:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.5:p113:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.5:p115:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.5:p12:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.5:p2:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.5:p35:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.5:preview1:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.5:preview2:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.5:preview3:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.5:preview4:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.5:preview5:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.6:*:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.6:p110:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.6:p111:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.6:p114:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.6:p230:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.6:p286:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.6:p36:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.6:preview1:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.6:preview2:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.6:preview3:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.7:*:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.7:p17:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.7:p22:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.7:p71:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.7:preview1:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.7:preview2:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.7:preview3:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.8.7:preview4:*:*:*:*:*:*
cpe:2.3:a:ruby-lang:ruby:1.9.0:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

5 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2008-3655
NVD Published Date:
08/12/2008
NVD Last Modified:
10/11/2018