National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2008-4221 Detail

Current Description

The strptime API in Libsystem in Apple Mac OS X before 10.5.6 allows context-dependent attackers to cause a denial of service (memory corruption and application crash) or execute arbitrary code via a crafted date string, related to improper memory allocation.

Source:  MITRE
View Analysis Description

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 10.0 HIGH
Vector: (AV:N/AC:L/Au:N/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Provides administrator access
Allows unauthorized disclosure of information
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.apple.com/archives/security-announce//2008//Dec/msg00000.html Vendor Advisory
http://support.apple.com/kb/HT3338 Vendor Advisory
http://www.securityfocus.com/bid/32839
http://www.securityfocus.com/bid/32881
http://www.securitytracker.com/id?1021406
http://www.us-cert.gov/cas/techalerts/TA08-350A.html US Government Resource
http://www.vupen.com/english/advisories/2008/3444

Technical Details

Vulnerability Type (View All)

  • Resource Management Errors (CWE-399)

Known Affected Software Configurations Switch to CPE 2.3

Configuration 1 ( hide )
 cpe:/o:apple:mac_os_x:10.4.11
     Show Matching CPE(s)
 cpe:/o:apple:mac_os_x:10.5
     Show Matching CPE(s)
 cpe:/o:apple:mac_os_x:10.5.1
     Show Matching CPE(s)
 cpe:/o:apple:mac_os_x:10.5.2
     Show Matching CPE(s)
 cpe:/o:apple:mac_os_x:10.5.3
     Show Matching CPE(s)
 cpe:/o:apple:mac_os_x:10.5.4
     Show Matching CPE(s)
 cpe:/o:apple:mac_os_x
     Show Matching CPE(s)
Up to (including)
10.5.5
 cpe:/o:apple:mac_os_x_server:10.4.11
     Show Matching CPE(s)
 cpe:/o:apple:mac_os_x_server:10.5
     Show Matching CPE(s)
 cpe:/o:apple:mac_os_x_server:10.5.1
     Show Matching CPE(s)
 cpe:/o:apple:mac_os_x_server:10.5.2
     Show Matching CPE(s)
 cpe:/o:apple:mac_os_x_server:10.5.3
     Show Matching CPE(s)
 cpe:/o:apple:mac_os_x_server:10.5.4
     Show Matching CPE(s)
 cpe:/o:apple:mac_os_x_server
     Show Matching CPE(s)
Up to (including)
10.5.5


Change History

1 change record found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2008-4221
NVD Published Date:
12/16/2008
NVD Last Modified:
03/07/2011