National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2008-6085 Detail

Current Description

Integer overflow in multiple F-Secure anti-virus products, including Internet Security 2006 through 2008, Anti-Virus 2006 through 2008, and others, when configured to scan inside compressed archives, allows remote attackers to execute arbitrary code via a crafted RPM compressed archive file, which triggers a buffer overflow.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: N/A
NVD score not yet provided.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://www.f-secure.com/security/fsc-2008-3.shtml Patch Vendor Advisory
http://www.securityfocus.com/bid/31846
http://www.securitytracker.com/id?1021073
http://www.vupen.com/english/advisories/2008/2874
https://exchange.xforce.ibmcloud.com/vulnerabilities/46016

Weakness Enumeration

CWE-ID CWE Name Source
CWE-189 Numeric Errors NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:f-secure:f-secure_anti-virus:7.02:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_anti-virus:2006:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_anti-virus:2007:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_anti-virus:2007:*:second:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_anti-virus:2008:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_anti-virus:2009:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_anti-virus_for_citrix_servers:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
7.00
 cpe:2.3:a:f-secure:f-secure_anti-virus_for_microsoft_exchange:6.62:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_anti-virus_for_microsoft_exchange:7.00:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_anti-virus_for_microsoft_exchange:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
7.10
 cpe:2.3:a:f-secure:f-secure_anti-virus_for_mimesweeper:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
5.61
 cpe:2.3:a:f-secure:f-secure_anti-virus_for_windows_servers:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
8.00
 cpe:2.3:a:f-secure:f-secure_anti-virus_for_workstations:7.10:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_anti-virus_for_workstations:7.11:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_anti-virus_linux_client_security:5.30:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_anti-virus_linux_client_security:5.52:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_anti-virus_linux_client_security:5.53:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_anti-virus_linux_client_security:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
5.54
 cpe:2.3:a:f-secure:f-secure_anti-virus_linux_server_security:5.30:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_anti-virus_linux_server_security:5.52:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_anti-virus_linux_server_security:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
5.54
 cpe:2.3:a:f-secure:f-secure_client_security:7.11:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_client_security:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
7.12
 cpe:2.3:a:f-secure:f-secure_home_server_security:2009:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_internet_gatekeeper_for_linux:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
2.16
 cpe:2.3:a:f-secure:f-secure_internet_gatekeeper_for_windows:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
6.61
 cpe:2.3:a:f-secure:f-secure_internet_security:7.02:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_internet_security:2006:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_internet_security:2007:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_internet_security:2007:*:second:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_internet_security:2008:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_internet_security:2009:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_linux_security:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
7.01
 cpe:2.3:a:f-secure:f-secure_messaging_security_gateway:4.0.7:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_messaging_security_gateway:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
5.0.4
 cpe:2.3:a:f-secure:f-secure_protection_service_for_business:3.00:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_protection_service_for_business:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
3.10
 cpe:2.3:a:f-secure:f-secure_protection_service_for_consumers:5.00:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_protection_service_for_consumers:6.00:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_protection_service_for_consumers:7.00:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:f-secure:f-secure_protection_service_for_consumers:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
8.00


Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2008-6085
NVD Published Date:
02/06/2009
NVD Last Modified:
08/07/2017