National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2009-0049 Detail

Current Description

Belgian eID middleware (eidlib) 2.6.0 and earlier does not properly check the return value from the OpenSSL EVP_VerifyFinal function, which allows remote attackers to bypass validation of the certificate chain via a malformed SSL/TLS signature for DSA and ECDSA keys, a similar vulnerability to CVE-2008-5077.

Source:  MITRE      Last Modified:  01/07/2009      View Analysis Description

Quick Info

CVE Dictionary Entry:
CVE-2009-0049
Original release date:
01/07/2009
Last revised:
10/30/2012
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
5.0 MEDIUM
Vector:
(AV:N/AC:L/Au:N/C:P/I:N/A:N) (legend)
Impact Subscore:
2.9
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows unauthorized disclosure of information

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://lists.opensuse.org/opensuse-security-announce/2009-03/msg00000.html External Source SUSE SUSE-SR:2009:005
http://www.ocert.org/advisories/ocert-2008-016.html External Source MISC http://www.ocert.org/advisories/ocert-2008-016.html
http://www.securityfocus.com/archive/1/archive/1/499827/100/0/threaded External Source BUGTRAQ 20090107 [oCERT-2008-016] Multiple OpenSSL signature verification API misuses

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:eid:eidlib:*:*:*:*:*:*:*:*    versions up to (including) 2.6.0

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 1 change record found - show changes