National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2009-3458 Detail

Description

Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9.x before 9.2 do not properly validate input, which might allow attackers to execute arbitrary code via unspecified vectors, a different vulnerability than CVE-2009-2998.

Source:  MITRE
Description Last Modified:  10/19/2009

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 9.3 HIGH
Vector: (AV:N/AC:M/Au:N/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

Evaluator Impact

Per: http://www.adobe.com/support/security/bulletins/apsb09-15.html Summary Critical vulnerabilities have been identified in Adobe Reader 9.1.3 and Acrobat 9.1.3, Adobe Reader 8.1.6 and Acrobat 8.1.6 for Windows, Macintosh and UNIX, and Adobe Reader 7.1.3 and Acrobat 7.1.3 for Windows and Macintosh. These vulnerabilities could cause the application to crash and could potentially allow an attacker to take control of the affected system. This update represents the second quarterly security update for Adobe Reader and Acrobat. Adobe recommends users of Adobe Reader 9.1.3 and Acrobat 9.1.3 and earlier versions update to Adobe Reader 9.2 and Acrobat 9.2. Adobe recommends users of Acrobat 8.1.6 and earlier versions update to Acrobat 8.1.7, and users of Acrobat 7.1.3 and earlier versions update to Acrobat 7.1.4. For Adobe Reader users who cannot update to Adobe Reader 9.2, Adobe has provided the Adobe Reader 8.1.7 and Adobe Reader 7.1.4 updates. Updates apply to all platforms: Windows, Macintosh and UNIX. Affected software versions Adobe Reader 9.1.3 and earlier versions for Windows, Macintosh, and UNIX Adobe Acrobat 9.1.3 and earlier versions for Windows and Macintosh

Evaluator Solution

Per: http://www.adobe.com/support/security/bulletins/apsb09-15.html Solution Adobe Reader Adobe Reader users on Windows can find the appropriate update here: http://www.adobe.com/support/downloads/product.jsp?product=10&platform=Windows. Adobe Reader users on Macintosh can find the appropriate update here: http://www.adobe.com/support/downloads/product.jsp?product=10&platform=Macintosh. Adobe Reader users on UNIX can find the appropriate update here: http://www.adobe.com/support/downloads/product.jsp?product=10&platform=Unix. Acrobat Acrobat Standard and Pro users on Windows can find the appropriate update here: http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Windows. Acrobat Pro Extended users on Windows can find the appropriate update here: http://www.adobe.com/support/downloads/product.jsp?product=158&platform=Windows Acrobat 3D users on Windows can find the appropriate update here: http://www.adobe.com/support/downloads/product.jsp?product=112&platform=Windows. Acrobat Pro users on Macintosh can find the appropriate update here: http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Macintosh. Severity rating

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://securitytracker.com/id?1023007
http://www.adobe.com/support/security/bulletins/apsb09-15.html Patch Vendor Advisory
http://www.securityfocus.com/bid/36638
http://www.us-cert.gov/cas/techalerts/TA09-286B.html Patch US Government Resource
http://www.vupen.com/english/advisories/2009/2898 Patch Vendor Advisory
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A6499

References to Check Content

Identifier:
oval:org.mitre.oval:def:6499
Check System:
http://oval.mitre.org/XMLSchema/oval-definitions-5
Hyperlink:
http://oval.mitre.org/repository/data/DownloadDefinition?id=oval:org.mitre.oval:def:6499

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:adobe:acrobat:7.0:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:7.0.1:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:7.0.2:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:7.0.3:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:7.0.4:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:7.0.5:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:7.0.6:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:7.0.7:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:7.0.8:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:7.0.9:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:7.1.0:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:7.1.1:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:7.1.3:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:8.0.0:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:8.1:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:8.1.1:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:8.1.2:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:8.1.3:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:8.1.4:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:8.1.6:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:9.0:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:9.1.1:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:9.1.2:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat:*:*:*:*:*:*:*:*    versions up to (including) 9.1.3
Configuration 2
OR
cpe:2.3:a:adobe:acrobat_reader:7.0:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:7.0.1:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:7.0.2:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:7.0.3:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:7.0.4:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:7.0.5:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:7.0.6:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:7.0.7:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:7.0.8:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:7.0.9:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:7.1.0:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:7.1.1:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:7.1.3:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:8.0:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:8.1:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:8.1.1:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:8.1.2:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:8.1.3:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:8.1.4:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:8.1.5:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:8.1.6:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:9.0:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:9.1:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:9.1.1:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:9.1.2:*:*:*:*:*:*:*
cpe:2.3:a:adobe:acrobat_reader:*:*:*:*:*:*:*:*    versions up to (including) 9.1.3

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2009-3458
NVD Published Date:
10/19/2009
NVD Last Modified:
09/18/2017