National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2009-3933 Detail

Current Description

WebKit before r50173, as used in Google Chrome before 3.0.195.32, allows remote attackers to cause a denial of service (CPU consumption) via a web page that calls the JavaScript setInterval method, which triggers an incompatibility between the WTF::currentTime and base::Time functions.

Source:  MITRE
View Analysis Description

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 5.0 MEDIUM
Vector: (AV:N/AC:L/Au:N/C:N/I:N/A:P) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): None
Integrity (I): None
Availability (A): Partial
Additional Information:
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://code.google.com/p/chromium/issues/detail?id=25892
http://codereview.chromium.org/339039 Patch
http://googlechromereleases.blogspot.com/2009/11/stable-channel-update.html Vendor Advisory
http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00006.html
http://src.chromium.org/viewvc/chrome/branches/195/src/webkit/webkit.gyp?r1=30311&r2=30310
http://src.chromium.org/viewvc/chrome?view=rev&revision=30311
http://trac.webkit.org/changeset/50173
http://www.vupen.com/english/advisories/2011/0212
https://bugs.webkit.org/show_bug.cgi?id=30833
https://exchange.xforce.ibmcloud.com/vulnerabilities/54297

Technical Details

Vulnerability Type (View All)

  • Resource Management Errors (CWE-399)

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:webkit:webkit:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
r50173
Running on/with
 cpe:2.3:a:google:chrome:0.2.149.27:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:0.2.149.29:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:0.2.149.30:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:0.2.152.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:0.2.153.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:0.3.154.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:0.3.154.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:0.4.154.18:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:0.4.154.22:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:0.4.154.31:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:0.4.154.33:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:1.0.154.36:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:1.0.154.39:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:1.0.154.42:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:1.0.154.43:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:1.0.154.46:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:1.0.154.48:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:1.0.154.52:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:1.0.154.53:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:1.0.154.59:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:1.0.154.65:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.156.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.157.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.157.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.158.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.159.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.169.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.169.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.170.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.172:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.172.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.172.8:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.172.27:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.172.28:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.172.30:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.172.31:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.172.33:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.172.37:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:2.0.172.38:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:3.0.182.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:3.0.190.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:3.0.193.2:beta:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:3.0.195.21:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
3.0.195.24


Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2009-3933
NVD Published Date:
11/12/2009
NVD Last Modified:
08/16/2017