CVE-2010-2939 Detail

Current Description

Double free vulnerability in the ssl3_get_key_exchange function in the OpenSSL client (ssl/s3_clnt.c) in OpenSSL 1.0.0a, 0.9.8, 0.9.7, and possibly other versions, when using ECDH, allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted private key with an invalid prime. NOTE: some sources refer to this as a use-after-free issue.


View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score:  N/A
NVD score not yet provided.


NVD Analysts use publicly available information to associate vector strings and CVSS scores. We also display any CVSS information provided within the CVE List from the CNA.

Note: NVD Analysts have not published a CVSS score for this CVE at this time. NVD Analysts use publicly available information at the time of analysis to associate CVSS vector strings.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.opensuse.org/opensuse-security-announce/2010-11/msg00005.html
http://marc.info/?l=bugtraq&m=130331363227777&w=2
http://seclists.org/fulldisclosure/2010/Aug/84
http://security.FreeBSD.org/advisories/FreeBSD-SA-10:10.openssl.asc
http://securitytracker.com/id?1024296
http://slackware.com/security/viewer.php?l=slackware-security&y=2010&m=slackware-security.668793
http://www.debian.org/security/2010/dsa-2100
http://www.mail-archive.com/openssl-dev@openssl.org/msg28043.html
http://www.mail-archive.com/openssl-dev@openssl.org/msg28045.html
http://www.mail-archive.com/openssl-dev@openssl.org/msg28049.html
http://www.openwall.com/lists/oss-security/2010/08/11/6
http://www.securityfocus.com/archive/1/516397/100/0/threaded
http://www.ubuntu.com/usn/USN-1003-1
http://www.vmware.com/security/advisories/VMSA-2011-0003.html
http://www.vupen.com/english/advisories/2010/2038 Vendor Advisory 
http://www.vupen.com/english/advisories/2010/2229
http://www.vupen.com/english/advisories/2010/3077

Weakness Enumeration

CWE-ID CWE Name Source
CWE-399 Resource Management Errors cwe source acceptance level NIST  

Known Affected Software Configurations Switch to CPE 2.2

CPEs loading, please wait.

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found show changes

Quick Info

CVE Dictionary Entry:
CVE-2010-2939
NVD Published Date:
08/17/2010
NVD Last Modified:
10/10/2018
Source:
Red Hat, Inc.