National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2010-3056 Detail

Current Description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 2.11.x before 2.11.10.1 and 3.x before 3.3.5.1 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) db_search.php, (2) db_sql.php, (3) db_structure.php, (4) js/messages.php, (5) libraries/common.lib.php, (6) libraries/database_interface.lib.php, (7) libraries/dbi/mysql.dbi.lib.php, (8) libraries/dbi/mysqli.dbi.lib.php, (9) libraries/db_info.inc.php, (10) libraries/sanitizing.lib.php, (11) libraries/sqlparser.lib.php, (12) server_databases.php, (13) server_privileges.php, (14) setup/config.php, (15) sql.php, (16) tbl_replace.php, and (17) tbl_sql.php.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: N/A
NVD score not yet provided.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.fedoraproject.org/pipermail/package-announce/2010-August/045991.html
http://lists.fedoraproject.org/pipermail/package-announce/2010-August/045997.html
http://www.debian.org/security/2010/dsa-2097
http://www.mandriva.com/security/advisories?name=MDVSA-2010:163
http://www.mandriva.com/security/advisories?name=MDVSA-2010:164
http://www.phpmyadmin.net/home_page/security/PMASA-2010-5.php Patch Vendor Advisory
http://www.securityfocus.com/bid/42584 Patch
http://www.vupen.com/english/advisories/2010/2223 Vendor Advisory
http://www.vupen.com/english/advisories/2010/2231
http://yehg.net/lab/pr0js/advisories/phpmyadmin/%5Bphpmyadmin-3.3.5%5D_cross_site_scripting%28XSS%29 Exploit
https://bugzilla.redhat.com/show_bug.cgi?id=625877

Weakness Enumeration

CWE-ID CWE Name Source
CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') NIST  

Known Affected Software Configurations Switch to CPE 2.3

Configuration 1 ( hide )
 cpe:/a:phpmyadmin:phpmyadmin:2.11.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.1.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.1.1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.1.2
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.2.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.2.1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.2.2
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.3.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.4.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.5.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.5.1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.5.2
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.6.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.7.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.7.1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.8.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.9.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.9.1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.9.2
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.9.3
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.9.4
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.9.5
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.9.6
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:2.11.10.0
     Show Matching CPE(s)

Configuration 2 ( hide )
 cpe:/a:phpmyadmin:phpmyadmin:3.0.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.0.0:alpha
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.0.0:beta
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.0.0:rc1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.0.1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.0.1:rc1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.0.1.1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.1.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.1.0:beta1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.1.1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.1.1:rc1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.1.2
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.1.2:rc1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.1.3
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.1.3:rc1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.1.3.1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.1.3.2
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.1.4
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.1.4:rc2
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.1.5
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.1.5:rc1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.2.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.2.0:beta1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.2.0:rc1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.2.1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.2.1:rc1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.2.2
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.2.2:rc1
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.3.0.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.3.1.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.3.2.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.3.3.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.3.4.0
     Show Matching CPE(s)
 cpe:/a:phpmyadmin:phpmyadmin:3.3.5.0
     Show Matching CPE(s)


Change History

1 change record found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2010-3056
NVD Published Date:
08/24/2010
NVD Last Modified:
01/28/2011