National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2011-1753 Detail

Description

expat_erl.c in ejabberd before 2.1.7 and 3.x before 3.0.0-alpha-3, and exmpp before 0.9.7, does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Source:  MITRE
Description Last Modified:  06/20/2011

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 5.0 MEDIUM
Vector: (AV:N/AC:L/Au:N/C:N/I:N/A:P) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): None
Integrity (I): None
Availability (A): Partial
Additional Information:
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.fedoraproject.org/pipermail/package-announce/2011-June/062099.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-June/062145.html
http://www.debian.org/security/2011/dsa-2248
http://www.ejabberd.im/ejabberd-2.1.7 Patch
http://www.process-one.net/en/ejabberd/release_notes/release_note_ejabberd_2.1.7/
http://www.securityfocus.com/bid/48072
https://bugzilla.redhat.com/show_bug.cgi?id=700454
https://exchange.xforce.ibmcloud.com/vulnerabilities/67769
https://git.process-one.net/ejabberd/mainline/commit/bd1df027c622e1f96f9eeaac612a6a956c1ff0b6 Patch

Technical Details

Vulnerability Type (View All)

  • Resource Management Errors (CWE-399)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:process-one:ejabberd:0.9:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:0.9.1:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:0.9.8:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:1.0.0:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:1.1.0:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:1.1.1:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:1.1.1.0:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:1.1.1.1:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:1.1.2:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:1.1.3:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:1.1.14:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:2.0.0:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:2.0.0:beta1:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:2.0.0:rc1:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:2.0.1_2:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:2.0.2:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:2.0.3:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:2.0.4:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:2.0.5:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:2.1.0:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:2.1.1:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:2.1.2:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:2.1.3:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:2.1.4:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:2.1.5:*:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:*:*:*:*:*:*:*:*    versions up to (including) 2.1.6
cpe:2.3:a:process-one:ejabberd:3.0.0:alpha1:*:*:*:*:*:*
cpe:2.3:a:process-one:ejabberd:3.0.0:alpha2:*:*:*:*:*:*
Configuration 2
OR
cpe:2.3:a:process-one:exmpp:0.9.1:*:*:*:*:*:*:*
cpe:2.3:a:process-one:exmpp:0.9.2:*:*:*:*:*:*:*
cpe:2.3:a:process-one:exmpp:0.9.3:*:*:*:*:*:*:*
cpe:2.3:a:process-one:exmpp:0.9.4:*:*:*:*:*:*:*
cpe:2.3:a:process-one:exmpp:0.9.5:*:*:*:*:*:*:*
cpe:2.3:a:process-one:exmpp:*:*:*:*:*:*:*:*    versions up to (including) 0.9.6

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2011-1753
NVD Published Date:
06/20/2011
NVD Last Modified:
08/16/2017