CVE-2011-2193 Detail

Current Description

Multiple buffer overflows in Terascale Open-Source Resource and Queue Manager (aka TORQUE Resource Manager) 2.x before 2.4.14, 2.5.x before 2.5.6, and 3.x before 3.0.2 allow (1) remote authenticated users to gain privileges via a long Job_Name field in a qsub command to the server, and might allow (2) local users to gain privileges via vectors involving a long host variable in pbs_iff.


View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score:  N/A
NVD score not yet provided.


NVD Analysts use publicly available information to associate vector strings and CVSS scores. We also display any CVSS information provided within the CVE List from the CNA.

Note: NVD Analysts have not published a CVSS score for this CVE at this time. NVD Analysts use publicly available information at the time of analysis to associate CVSS vector strings.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.fedoraproject.org/pipermail/package-announce/2011-July/062638.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-June/061645.html
http://securityreason.com/securityalert/8304
http://www.clusterresources.com/downloads/torque/CHANGELOGS/torque-2.4.14.CHANGELOG
http://www.clusterresources.com/downloads/torque/CHANGELOGS/torque-2.5.6.CHANGELOG
http://www.debian.org/security/2011/dsa-2329
http://www.securityfocus.com/archive/1/518885/100/0/threaded
http://www.securityfocus.com/bid/48374
https://bugzilla.redhat.com/show_bug.cgi?id=711463 Patch 
https://exchange.xforce.ibmcloud.com/vulnerabilities/68151
https://exchange.xforce.ibmcloud.com/vulnerabilities/68152

Weakness Enumeration

CWE-ID CWE Name Source
CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer cwe source acceptance level NIST  

Known Affected Software Configurations Switch to CPE 2.2

CPEs loading, please wait.

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

3 change records found show changes

Quick Info

CVE Dictionary Entry:
CVE-2011-2193
NVD Published Date:
06/24/2011
NVD Last Modified:
10/09/2018
Source:
MITRE