National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2011-3148 Detail

Current Description

Stack-based buffer overflow in the _assemble_line function in modules/pam_env/pam_env.c in Linux-PAM (aka pam) before 1.1.5 allows local users to cause a denial of service (crash) and possibly execute arbitrary code via a long string of white spaces at the beginning of the ~/.pam_environment file.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: N/A
NVD score not yet provided.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://git.fedorahosted.org/git/?p=linux-pam.git;a=commitdiff;h=caf5e7f61c8d9288daa49b4f61962e6b1239121d Exploit Patch
http://security.gentoo.org/glsa/glsa-201206-31.xml
http://www.ubuntu.com/usn/USN-1237-1
https://bugs.launchpad.net/ubuntu/+source/pam/+bug/874469

Weakness Enumeration

CWE-ID CWE Name Source
CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:linux-pam:linux-pam:0.99.1.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:0.99.2.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:0.99.2.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:0.99.3.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:0.99.4.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:0.99.5.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:0.99.6.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:0.99.6.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:0.99.6.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:0.99.6.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:0.99.7.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:0.99.7.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:0.99.8.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:0.99.8.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:0.99.9.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:0.99.10.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:1.0.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:1.0.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:1.0.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:1.0.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:1.0.4:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:1.1.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:1.1.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:1.1.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:1.1.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:linux-pam:linux-pam:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
1.1.4


Change History

27 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2011-3148
NVD Published Date:
07/22/2012
NVD Last Modified:
01/03/2019