National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2012-2136 Detail

Description

The sock_alloc_send_pskb function in net/core/sock.c in the Linux kernel before 3.4.5 does not properly validate a certain length value, which allows local users to cause a denial of service (heap-based buffer overflow and system crash) or possibly gain privileges by leveraging access to a TUN/TAP device.

Source:  MITRE
Description Last Modified:  08/09/2012

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 7.2 HIGH
Vector: (AV:L/AC:L/Au:N/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 3.9


Access Vector (AV): Local
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=cc9b17ad29ecaa20bfe426a8d4dbfb94b13ff1cc
http://rhn.redhat.com/errata/RHSA-2012-0743.html
http://rhn.redhat.com/errata/RHSA-2012-1087.html
http://ubuntu.com/usn/usn-1529-1
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.4.5
http://www.securityfocus.com/bid/53721
http://www.ubuntu.com/usn/USN-1535-1
https://bugzilla.redhat.com/show_bug.cgi?id=816289
https://github.com/torvalds/linux/commit/cc9b17ad29ecaa20bfe426a8d4dbfb94b13ff1cc Exploit Patch

Technical Details

Vulnerability Type (View All)

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:o:linux:linux_kernel:3.4:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:3.4:rc1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:3.4:rc2:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:3.4:rc3:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:3.4:rc4:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:3.4:rc5:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:3.4:rc6:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:3.4:rc7:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:3.4.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:3.4.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:3.4.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
3.4.4


Change History

1 change record found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2012-2136
NVD Published Date:
08/09/2012
NVD Last Modified:
03/01/2013