National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2012-5274 Detail

Description

Buffer overflow in Adobe Flash Player before 10.3.183.43 and 11.x before 11.5.502.110 on Windows and Mac OS X, before 10.3.183.43 and 11.x before 11.2.202.251 on Linux, before 11.1.111.24 on Android 2.x and 3.x, and before 11.1.115.27 on Android 4.x; Adobe AIR before 3.5.0.600; and Adobe AIR SDK before 3.5.0.600 allows attackers to execute arbitrary code via unspecified vectors, a different vulnerability than CVE-2012-5275, CVE-2012-5276, CVE-2012-5277, and CVE-2012-5280.

Source:  MITRE      Last Modified:  11/07/2012

Quick Info

CVE Dictionary Entry:
CVE-2012-5274
Original release date:
11/07/2012
Last revised:
08/28/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
10.0 HIGH
Vector:
(AV:N/AC:L/Au:N/C:C/I:C/A:C) (legend)
Impact Subscore:
10.0
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://lists.opensuse.org/opensuse-security-announce/2012-11/msg00005.html External Source SUSE openSUSE-SU-2012:1480
http://lists.opensuse.org/opensuse-security-announce/2012-11/msg00007.html External Source SUSE SUSE-SU-2012:1485
http://lists.opensuse.org/opensuse-security-announce/2013-01/msg00012.html External Source SUSE openSUSE-SU-2013:0134
http://lists.opensuse.org/opensuse-security-announce/2013-02/msg00030.html External Source SUSE openSUSE-SU-2013:0367
http://rhn.redhat.com/errata/RHSA-2012-1431.html External Source REDHAT RHSA-2012:1431
http://www.adobe.com/support/security/bulletins/apsb12-24.html Patch; Vendor Advisory External Source CONFIRM http://www.adobe.com/support/security/bulletins/apsb12-24.html
http://www.securitytracker.com/id?1027730 External Source SECTRACK 1027730
https://exchange.xforce.ibmcloud.com/vulnerabilities/79845 External Source XF adobe-cve20125274-bo(79845)

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
AND
OR
cpe:2.3:a:adobe:flash_player:10.1.85.3:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.1.102.64:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.2.152.26:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.2.152.32:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.2.153.1:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.2.159.1:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.181.14:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.181.16:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.181.22:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.181.26:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.181.34:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.5:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.7:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.10:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.11:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.15:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.16:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.18:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.20:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.23:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:*:*:*:*:*:*:*:*    versions up to (including) 10.3.183.25
cpe:2.3:a:adobe:flash_player:11.0.1.152:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.1.102.55:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.1.102.62:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.1.102.63:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.2.202.223:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.2.202.228:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.2.202.233:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.2.202.235:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.2.202.238:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.2.202.243:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.3.300.257:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.3.300.262:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.3.300.265:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.3.300.268:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.3.300.271:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.3.300.273:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.4.402.265:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:*:*:*:*:*:*:*:*    versions up to (including) 11.4.402.278
OR
cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:*
cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:*
Configuration 2
AND
OR
cpe:2.3:a:adobe:flash_player:10.1.85.3:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.1.102.64:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.2.152.26:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.2.152.32:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.2.153.1:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.2.159.1:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.181.14:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.181.16:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.181.22:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.181.26:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.181.34:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.5:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.7:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.10:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.11:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.15:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.16:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.18:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.20:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:10.3.183.23:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:*:*:*:*:*:*:*:*    versions up to (including) 10.3.183.25
cpe:2.3:a:adobe:flash_player:11.0:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.0.1.152:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.0.1.153:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.1:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.1.102.55:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.1.102.62:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.1.102.63:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.2.202.223:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.2.202.228:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.2.202.233:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:11.2.202.235:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:*:*:*:*:*:*:*:*    versions up to (including) 11.2.202.238
OR
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*
Configuration 3
AND
OR
cpe:2.3:a:adobe:flash_player_for_android:10.1.106.17:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player_for_android:10.2.157.51:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player_for_android:10.3.186.7:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player_for_android:11.0.1.153:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player_for_android:11.1.102.59:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player_for_android:11.1.111.5:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player_for_android:11.1.111.7:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player_for_android:11.1.111.8:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player_for_android:11.1.111.9:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player_for_android:11.1.111.10:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player_for_android:*:*:*:*:*:*:*:*    versions up to (including) 11.1.111.16
OR
cpe:2.3:o:google:android:2.0:*:*:*:*:*:*:*
cpe:2.3:o:google:android:2.0.1:*:*:*:*:*:*:*
cpe:2.3:o:google:android:2.1:*:*:*:*:*:*:*
cpe:2.3:o:google:android:2.2:*:*:*:*:*:*:*
cpe:2.3:o:google:android:2.2:rev1:*:*:*:*:*:*
cpe:2.3:o:google:android:2.2.1:*:*:*:*:*:*:*
cpe:2.3:o:google:android:2.2.2:*:*:*:*:*:*:*
cpe:2.3:o:google:android:2.2.3:*:*:*:*:*:*:*
cpe:2.3:o:google:android:2.3:*:*:*:*:*:*:*
cpe:2.3:o:google:android:2.3:rev1:*:*:*:*:*:*
cpe:2.3:o:google:android:2.3.1:*:*:*:*:*:*:*
cpe:2.3:o:google:android:2.3.2:*:*:*:*:*:*:*
cpe:2.3:o:google:android:2.3.3:*:*:*:*:*:*:*
cpe:2.3:o:google:android:2.3.4:*:*:*:*:*:*:*
cpe:2.3:o:google:android:2.3.5:*:*:*:*:*:*:*
Configuration 4
Configuration 5
Configuration 6
Showing 100 of 164 CPEs, view all CPEs here.

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 3 change records found - show changes