National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2013-1892 Detail

Current Description

MongoDB before 2.0.9 and 2.2.x before 2.2.4 does not properly validate requests to the nativeHelper function in SpiderMonkey, which allows remote authenticated users to cause a denial of service (invalid memory access and server crash) or execute arbitrary code via a crafted memory address in the first argument.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: N/A
NVD score not yet provided.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://blog.scrt.ch/2013/03/24/mongodb-0-day-ssji-to-rce/ Exploit
http://lists.fedoraproject.org/pipermail/package-announce/2013-April/101630.html
http://lists.fedoraproject.org/pipermail/package-announce/2013-April/101679.html
http://rhn.redhat.com/errata/RHSA-2013-1170.html Vendor Advisory
http://www.exploit-db.com/exploits/24935
http://www.exploit-db.com/exploits/24947
http://www.mongodb.org/about/alerts/ Vendor Advisory
http://www.openwall.com/lists/oss-security/2013/03/25/9
https://jira.mongodb.org/browse/SERVER-9124

Weakness Enumeration

CWE-ID CWE Name Source
CWE-20 Improper Input Validation NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:mongodb:mongodb:1.2.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mongodb:mongodb:1.4.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mongodb:mongodb:1.6.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mongodb:mongodb:1.8.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mongodb:mongodb:2.0.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mongodb:mongodb:2.0.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mongodb:mongodb:2.0.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mongodb:mongodb:2.0.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mongodb:mongodb:2.0.4:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mongodb:mongodb:2.0.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mongodb:mongodb:2.0.6:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mongodb:mongodb:2.0.7:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
2.0.8
 cpe:2.3:a:mongodb:mongodb:2.2.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mongodb:mongodb:2.2.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mongodb:mongodb:2.2.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mongodb:mongodb:2.2.3:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 2 ( hide )
 cpe:2.3:a:redhat:enterprise_mrg:2.3:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

1 change record found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2013-1892
NVD Published Date:
10/01/2013
NVD Last Modified:
11/30/2013