National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2013-4479 Detail

Current Description

lib/sup/message_chunks.rb in Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the content_type of an email attachment.

Source:  MITRE
View Analysis Description

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 6.8 MEDIUM
Vector: (AV:N/AC:M/Au:N/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.fedoraproject.org/pipermail/package-announce/2015-September/165917.html
http://rubyforge.org/pipermail/sup-talk/2013-October/004996.html
http://seclists.org/fulldisclosure/2013/Oct/272
http://www.openwall.com/lists/oss-security/2013/10/30/2
https://github.com/sup-heliotrope/sup/commit/ca0302e0c716682d2de22e9136400c704cc93e42 Exploit Patch

Technical Details

Vulnerability Type (View All)

Known Affected Software Configurations Switch to CPE 2.3

Configuration 1 ( hide )
 cpe:/a:supmua:sup:0.13.0
     Show Matching CPE(s)
 cpe:/a:supmua:sup:0.13.1
     Show Matching CPE(s)
 cpe:/a:supmua:sup
     Show Matching CPE(s)
Up to (including)
0.13.2
 cpe:/a:supmua:sup:0.14.0
     Show Matching CPE(s)
 cpe:/a:supmua:sup:0.14.1
     Show Matching CPE(s)


Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2013-4479
NVD Published Date:
12/07/2013
NVD Last Modified:
12/21/2016