National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2014-0190 Detail

Description

The GIF decoder in QtGui in Qt before 5.3 allows remote attackers to cause a denial of service (NULL pointer dereference) via invalid width and height values in a GIF image.

Source:  MITRE
Description Last Modified:  05/08/2014

Evaluator Description

Per: http://cwe.mitre.org/data/definitions/476.html "CWE-476: NULL Pointer Dereference"

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 4.3 MEDIUM
Vector: (AV:N/AC:M/Au:N/C:N/I:N/A:P) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): None
Integrity (I): None
Availability (A): Partial
Additional Information:
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.fedoraproject.org/pipermail/package-announce/2014-June/134040.html
http://lists.fedoraproject.org/pipermail/package-announce/2014-June/134141.html
http://lists.fedoraproject.org/pipermail/package-announce/2014-May/132395.html
http://lists.opensuse.org/opensuse-updates/2015-03/msg00068.html
http://lists.qt-project.org/pipermail/announce/2014-April/000045.html Vendor Advisory
http://www.securityfocus.com/bid/67087
http://www.ubuntu.com/usn/USN-2626-1
https://bugs.kde.org/show_bug.cgi?id=333404

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:*
Configuration 2
OR
cpe:2.3:a:digia:qt:4.0.0:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.0.1:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.1.0:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.1.1:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.1.2:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.1.3:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.1.4:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.1.5:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.2.0:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.2.1:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.2.3:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.3.0:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.3.1:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.3.2:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.3.3:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.3.4:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.3.5:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.4.0:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.4.1:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.4.2:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.4.3:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.5.0:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.5.1:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.5.2:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.5.3:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.6.0:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.6.0:rc1:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.6.1:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.6.2:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.6.3:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.6.4:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.6.5:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.6.5:rc:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.7.0:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.7.1:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.7.2:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.7.3:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.7.4:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.7.5:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.7.6:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.7.6:rc:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.8.0:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.8.1:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.8.2:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.8.3:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.8.4:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:4.8.5:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:5.0.0:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:5.0.1:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:5.0.2:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:5.1.0:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:5.2.0:*:*:*:*:*:*:*
cpe:2.3:a:digia:qt:*:*:*:*:*:*:*:*    versions up to (including) 5.2.1
cpe:2.3:o:fedoraproject:fedora:20:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

5 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2014-0190
NVD Published Date:
05/08/2014
NVD Last Modified:
10/30/2018