National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2014-1609 Detail

Current Description

Multiple SQL injection vulnerabilities in MantisBT before 1.2.16 allow remote attackers to execute arbitrary SQL commands via unspecified parameters to the (1) mc_project_get_attachments function in api/soap/mc_project_api.php; the (2) news_get_limited_rows function in core/news_api.php; the (3) summary_print_by_enum, (4) summary_print_by_age, (5) summary_print_by_developer, (6) summary_print_by_reporter, or (7) summary_print_by_category function in core/summary_api.php; the (8) create_bug_enum_summary or (9) enum_bug_group function in plugins/MantisGraph/core/graph_api.php; (10) bug_graph_bycategory.php or (11) bug_graph_bystatus.php in plugins/MantisGraph/pages/; or (12) proj_doc_page.php, related to use of the db_query function, a different vulnerability than CVE-2014-1608.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: N/A
NVD score not yet provided.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://secunia.com/advisories/61432
http://www.debian.org/security/2014/dsa-3030
http://www.mantisbt.org/bugs/view.php?id=16880
http://www.ocert.org/advisories/ocert-2014-001.html US Government Resource
http://www.securityfocus.com/bid/65461
https://bugzilla.redhat.com/show_bug.cgi?id=1063111
https://github.com/mantisbt/mantisbt/commit/7efe0175f0853e18ebfacedfd2374c4179028b3f Exploit Patch

Weakness Enumeration

CWE-ID CWE Name Source
CWE-89 Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 2 ( hide )
 cpe:2.3:a:mantisbt:mantisbt:1.2.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.0:a1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.0:a2:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.0:a3:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.0:rc1:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.0:rc2:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.4:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.6:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.7:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.8:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.9:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.10:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.11:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.13:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:1.2.14:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mantisbt:mantisbt:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
1.2.15


Change History

4 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2014-1609
NVD Published Date:
03/20/2014
NVD Last Modified:
01/06/2017