National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2014-3025 Detail

Description

Multiple cross-site scripting (XSS) vulnerabilities in IBM Maximo Asset Management 6.2 through 6.2.8, 6.x and 7.1 through 7.1.1.2, and 7.5 through 7.5.0.6; Maximo Asset Management 7.5 through 7.5.0.3 and 7.5.1 through 7.5.1.2 for SmartCloud Control Desk; and Maximo Asset Management 6.2 through 6.2.8, 7.1 through 7.1.1.2, and 7.2 for Tivoli Asset Management for IT and certain other products allow remote authenticated users to inject arbitrary web script or HTML via unspecified input to a .jsp file under webclient/utility/.

Source:  MITRE
Description Last Modified:  07/30/2014

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 3.5 LOW
Vector: (AV:N/AC:M/Au:S/C:N/I:P/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 6.8


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): Single
Confidentiality (C): None
Integrity (I): Partial
Availability (A): None
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://secunia.com/advisories/59570
http://secunia.com/advisories/59640
http://www-01.ibm.com/support/docview.wss?uid=swg1IV57241
http://www-01.ibm.com/support/docview.wss?uid=swg21678754 Patch Vendor Advisory
https://exchange.xforce.ibmcloud.com/vulnerabilities/93064

Technical Details

Vulnerability Type (View All)

  • Cross-Site Scripting (XSS) (CWE-79)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:ibm:maximo_asset_management:6.2:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:6.2.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:6.2.2:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:6.2.3:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:6.2.4:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:6.2.5:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:6.2.6:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:6.2.6.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:6.2.7:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:6.2.8:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.1.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.1.1.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.1.1.2:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.1.1.5:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.1.1.6:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.1.1.7:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.1.1.8:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.1.1.9:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.1.1.10:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.1.1.11:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.1.1.12:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.1.2:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.5.0.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.5.0.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.5.0.2:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.5.0.3:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.5.0.4:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.5.0.5:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.5.0.6:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management:7.5.0.10:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management_essentials:6.2.0.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management_essentials:7.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management_essentials:7.5.0.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management_essentials:7.5.0.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management_essentials:7.5.0.2:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management_essentials:7.5.0.3:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management_essentials:7.5.0.4:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management_essentials:7.5.0.5:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_asset_management_essentials:*:*:*:*:*:*:*:*    versions up to (including) 7.5.0.6
cpe:2.3:a:ibm:maximo_for_government:7.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_government:7.5.0.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_government:7.5.0.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_government:7.5.0.2:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_government:7.5.0.3:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_government:7.5.0.4:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_government:7.5.0.5:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_government:*:*:*:*:*:*:*:*    versions up to (including) 7.5.0.6
cpe:2.3:a:ibm:maximo_for_life_sciences:7.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_life_sciences:7.5.0.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_life_sciences:7.5.0.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_life_sciences:7.5.0.2:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_life_sciences:7.5.0.3:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_life_sciences:7.5.0.4:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_life_sciences:7.5.0.5:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_life_sciences:*:*:*:*:*:*:*:*    versions up to (including) 7.5.0.6
cpe:2.3:a:ibm:maximo_for_nuclear_power:7.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_nuclear_power:7.5.0.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_nuclear_power:7.5.0.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_nuclear_power:7.5.0.2:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_nuclear_power:7.5.0.3:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_nuclear_power:7.5.0.4:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_nuclear_power:7.5.0.5:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_nuclear_power:*:*:*:*:*:*:*:*    versions up to (including) 7.5.0.6
cpe:2.3:a:ibm:maximo_for_oil_and_gas:7.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_oil_and_gas:7.5.0.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_oil_and_gas:7.5.0.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_oil_and_gas:7.5.0.2:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_oil_and_gas:7.5.0.3:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_oil_and_gas:7.5.0.4:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_oil_and_gas:7.5.0.5:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_oil_and_gas:*:*:*:*:*:*:*:*    versions up to (including) 7.5.0.6
cpe:2.3:a:ibm:maximo_for_transportation:7.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_transportation:7.5.0.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_transportation:7.5.0.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_transportation:7.5.0.2:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_transportation:7.5.0.3:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_transportation:7.5.0.4:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_transportation:7.5.0.5:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_transportation:*:*:*:*:*:*:*:*    versions up to (including) 7.5.0.6
cpe:2.3:a:ibm:maximo_for_utilities:7.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_utilities:7.5.0.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_utilities:7.5.0.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_utilities:7.5.0.2:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_utilities:7.5.0.3:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_utilities:7.5.0.4:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_utilities:7.5.0.5:*:*:*:*:*:*:*
cpe:2.3:a:ibm:maximo_for_utilities:*:*:*:*:*:*:*:*    versions up to (including) 7.5.0.6
cpe:2.3:a:ibm:maximo_service_desk:*:*:*:*:*:*:*:*    versions up to (including) 6.2.8
cpe:2.3:a:ibm:smartcloud_control_desk:7.5:*:*:*:*:*:*:*
cpe:2.3:a:ibm:smartcloud_control_desk:7.5.0.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:smartcloud_control_desk:7.5.0.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:smartcloud_control_desk:7.5.0.2:*:*:*:*:*:*:*
cpe:2.3:a:ibm:smartcloud_control_desk:7.5.0.3:*:*:*:*:*:*:*
cpe:2.3:a:ibm:smartcloud_control_desk:*:*:*:*:*:*:*:*    versions up to (including) 7.5.0.6
cpe:2.3:a:ibm:smartcloud_control_desk:7.5.1.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:smartcloud_control_desk:7.5.1.1:*:*:*:*:*:*:*
cpe:2.3:a:ibm:smartcloud_control_desk:7.5.1.2:*:*:*:*:*:*:*
cpe:2.3:a:ibm:tivoli_it_asset_management_for_it:*:*:*:*:*:*:*:*    versions up to (including) 6.2.8

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2014-3025
NVD Published Date:
07/30/2014
NVD Last Modified:
08/28/2017