National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2014-3544 Detail

Description

Cross-site scripting (XSS) vulnerability in user/profile.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via the Skype ID profile field.

Source:  MITRE
Description Last Modified:  07/29/2014

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 3.5 LOW
Vector: (AV:N/AC:M/Au:S/C:N/I:P/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 6.8


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): Single
Confidentiality (C): None
Integrity (I): Partial
Availability (A): None
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-45683 Patch
http://openwall.com/lists/oss-security/2014/07/21/1
http://osandamalith.wordpress.com/2014/07/25/moodle-2-7-persistent-xss/ Exploit
http://packetstormsecurity.com/files/127624/Moodle-2.7-Cross-Site-Scripting.html Exploit
http://www.exploit-db.com/exploits/34169
http://www.securityfocus.com/bid/68756
https://github.com/moodle/moodle/commit/ce5a785b0962c3c94c7a7b0d36176482d21db95d Patch
https://moodle.org/mod/forum/discuss.php?d=264265 Vendor Advisory

Technical Details

Vulnerability Type (View All)

  • Cross-Site Scripting (XSS) (CWE-79)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:moodle:moodle:2.4:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.4.1:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.4.2:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.4.3:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.4.4:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.4.5:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.4.6:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.4.7:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.4.8:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.4.9:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.4.10:*:*:*:*:*:*:*
Configuration 2
OR
cpe:2.3:a:moodle:moodle:2.3:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.3.1:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.3.2:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.3.3:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.3.4:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.3.5:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.3.6:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.3.7:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.3.8:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.3.9:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.3.10:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*    versions up to (including) 2.3.11
Configuration 3
OR
cpe:2.3:a:moodle:moodle:2.6:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.6.1:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.6.2:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.6.3:*:*:*:*:*:*:*
Configuration 4
OR
cpe:2.3:a:moodle:moodle:2.7:*:*:*:*:*:*:*
Configuration 5
OR
cpe:2.3:a:moodle:moodle:2.5:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.5.1:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.5.2:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.5.3:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.5.4:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.5.5:*:*:*:*:*:*:*
cpe:2.3:a:moodle:moodle:2.5.6:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2014-3544
NVD Published Date:
07/29/2014
NVD Last Modified:
08/31/2015