National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2014-4164 Detail

Current Description

Cross-site scripting (XSS) vulnerability in AlgoSec FireFlow 6.3-b230 allows remote attackers to inject arbitrary web script or HTML via a user signature to SelfService/Prefs.html.

Source:  MITRE
Description Last Modified:  06/16/2014
View Analysis Description

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 4.3 MEDIUM
Vector: (AV:N/AC:M/Au:N/C:N/I:P/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): None
Integrity (I): Partial
Availability (A): None
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized modification

Vendor Statements (disclaimer)

Official Statement from AlgoSec (08/06/2014)

This vulnerability has been fixed in AlgoSec FireFlow version 6.3 and on. Customers should upgrade to FireFlow version 6.3-b119 or later, 6.4-b170 or later, or any version of 6.5 or 6.6. Note that FireFlow 6.4 and below are already past their end-of-support date, and AlgoSec recommends that customers upgrade to a supported version. As of July 2014 the latest generally available version is 6.6.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://packetstormsecurity.com/files/127001/AlogoSec-FireFlow-6.3-Cross-Site-Scripting.html Exploit

Technical Details

Vulnerability Type (View All)

  • Cross-Site Scripting (XSS) (CWE-79)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:algosec:fireflow:6.3:b230:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2014-4164
NVD Published Date:
06/16/2014
NVD Last Modified:
12/04/2015