National Vulnerability Database

National Vulnerability Database

National Vulnerability

CVE-2014-4164 Detail

Current Description

Cross-site scripting (XSS) vulnerability in AlgoSec FireFlow 6.3-b230 allows remote attackers to inject arbitrary web script or HTML via a user signature to SelfService/Prefs.html.

Source:  MITRE      Last Modified:  06/16/2014      View Analysis Description

Quick Info

CVE Dictionary Entry:
Original release date:
Last revised:


CVSS Severity (version 2.0):
CVSS v2 Base Score:
(AV:N/AC:M/Au:N/C:N/I:P/A:N) (legend)
Impact Subscore:
Exploitability Subscore:
CVSS Version 2 Metrics:
Access Vector:
Network exploitable - Victim must voluntarily interact with attack mechanism
Access Complexity:
Not required to exploit
Impact Type:
Allows unauthorized modification

Vendor Statements (disclaimer)

Official Statement from AlgoSec (08/06/2014)

This vulnerability has been fixed in AlgoSec FireFlow version 6.3 and on. Customers should upgrade to FireFlow version 6.3-b119 or later, 6.4-b170 or later, or any version of 6.5 or 6.6. Note that FireFlow 6.4 and below are already past their end-of-support date, and AlgoSec recommends that customers upgrade to a supported version. As of July 2014 the latest generally available version is 6.6.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to

Hyperlink Resource Type Source Name Exploit External Source MISC

Technical Details

Vulnerability Type (View All)

  • Cross-Site Scripting (XSS) (CWE-79)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 2 change records found - show changes