National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2014-5241 Detail

Description

The JSONP endpoint in includes/api/ApiFormatJson.php in MediaWiki before 1.19.18, 1.20.x through 1.22.x before 1.22.9, and 1.23.x before 1.23.2 accepts certain long callback values and does not restrict the initial bytes of a JSONP response, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks, and obtain sensitive information, via a crafted OBJECT element with SWF content consistent with a restricted character set.

Source:  MITRE
Description Last Modified:  08/22/2014

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 6.8 MEDIUM
Vector: (AV:N/AC:M/Au:N/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://advisories.mageia.org/MGASA-2014-0309.html
http://openwall.com/lists/oss-security/2014/08/14/5
http://secunia.com/advisories/59738
http://www.debian.org/security/2014/dsa-3011
http://www.mandriva.com/security/advisories?name=MDVSA-2014:153
https://bugzilla.wikimedia.org/show_bug.cgi?id=68187 Exploit Patch Vendor Advisory
https://lists.wikimedia.org/pipermail/mediawiki-announce/2014-July/000157.html

Technical Details

Vulnerability Type (View All)

  • Cross-Site Request Forgery (CSRF) (CWE-352)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:mediawiki:mediawiki:1.19:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19:beta_1:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19:beta_2:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.0:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.1:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.2:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.3:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.4:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.5:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.6:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.7:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.8:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.9:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.10:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.11:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.12:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.13:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.14:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.15:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.19.16:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:*    versions up to (including) 1.19.17
cpe:2.3:a:mediawiki:mediawiki:1.20.1:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.20.2:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.20.3:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.20.4:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.20.5:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.20.6:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.20.7:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.20.8:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.21.1:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.21.2:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.21.3:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.21.4:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.21.5:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.21.6:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.21.7:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.21.8:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.21.9:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.21.10:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.22.0:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.22.1:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.22.2:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.22.3:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.22.4:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.22.5:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.22.6:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.22.7:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.22.8:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.23.0:*:*:*:*:*:*:*
cpe:2.3:a:mediawiki:mediawiki:1.23.1:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

4 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2014-5241
NVD Published Date:
08/22/2014
NVD Last Modified:
01/06/2017