National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2014-5273 Detail

Description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.2, 4.1.x before 4.1.14.3, and 4.2.x before 4.2.7.1 allow remote authenticated users to inject arbitrary web script or HTML via the (1) browse table page, related to js/sql.js; (2) ENUM editor page, related to js/functions.js; (3) monitor page, related to js/server_status_monitor.js; (4) query charts page, related to js/tbl_chart.js; or (5) table relations page, related to libraries/tbl_relation.lib.php.

Source:  MITRE
Description Last Modified:  08/21/2014

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 3.5 LOW
Vector: (AV:N/AC:M/Au:S/C:N/I:P/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 6.8


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): Single
Confidentiality (C): None
Integrity (I): Partial
Availability (A): None
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.opensuse.org/opensuse-updates/2014-08/msg00045.html
http://www.phpmyadmin.net/home_page/security/PMASA-2014-8.php Vendor Advisory
https://github.com/phpmyadmin/phpmyadmin/commit/2c45d7caa614afd71dbe3d0f7270f51ce5569614 Exploit Patch
https://github.com/phpmyadmin/phpmyadmin/commit/3ffc967fb60cf2910cc2f571017e977558c67821 Exploit Patch
https://github.com/phpmyadmin/phpmyadmin/commit/647c9d12e33a6b64e1c3ff7487f72696bdf2dccb Exploit Patch
https://github.com/phpmyadmin/phpmyadmin/commit/90ddeecf60fc029608b972e490b735f3a65ed0cb Exploit Patch
https://github.com/phpmyadmin/phpmyadmin/commit/cd9f302bf7f91a160fe7080f9a612019ef847f1c Exploit Patch

Technical Details

Vulnerability Type (View All)

  • Cross-Site Scripting (XSS) (CWE-79)

Vulnerable software and versions Switch to CPE 2.3

Configuration 1
OR
cpe:/a:phpmyadmin:phpmyadmin:4.0.0
cpe:/a:phpmyadmin:phpmyadmin:4.0.0:rc2
cpe:/a:phpmyadmin:phpmyadmin:4.0.0:rc3
cpe:/a:phpmyadmin:phpmyadmin:4.0.1
cpe:/a:phpmyadmin:phpmyadmin:4.0.2
cpe:/a:phpmyadmin:phpmyadmin:4.0.3
cpe:/a:phpmyadmin:phpmyadmin:4.0.4
cpe:/a:phpmyadmin:phpmyadmin:4.0.4.1
cpe:/a:phpmyadmin:phpmyadmin:4.0.4.2
cpe:/a:phpmyadmin:phpmyadmin:4.0.5
cpe:/a:phpmyadmin:phpmyadmin:4.0.6
cpe:/a:phpmyadmin:phpmyadmin:4.0.7
cpe:/a:phpmyadmin:phpmyadmin:4.0.8
cpe:/a:phpmyadmin:phpmyadmin:4.0.9
cpe:/a:phpmyadmin:phpmyadmin:4.0.10
cpe:/a:phpmyadmin:phpmyadmin:4.0.10.1
Configuration 2
OR
cpe:/a:phpmyadmin:phpmyadmin:4.1.0
cpe:/a:phpmyadmin:phpmyadmin:4.1.1
cpe:/a:phpmyadmin:phpmyadmin:4.1.2
cpe:/a:phpmyadmin:phpmyadmin:4.1.3
cpe:/a:phpmyadmin:phpmyadmin:4.1.4
cpe:/a:phpmyadmin:phpmyadmin:4.1.5
cpe:/a:phpmyadmin:phpmyadmin:4.1.6
cpe:/a:phpmyadmin:phpmyadmin:4.1.7
cpe:/a:phpmyadmin:phpmyadmin:4.1.8
cpe:/a:phpmyadmin:phpmyadmin:4.1.9
cpe:/a:phpmyadmin:phpmyadmin:4.1.10
cpe:/a:phpmyadmin:phpmyadmin:4.1.11
cpe:/a:phpmyadmin:phpmyadmin:4.1.12
cpe:/a:phpmyadmin:phpmyadmin:4.1.13
cpe:/a:phpmyadmin:phpmyadmin:4.1.14
cpe:/a:phpmyadmin:phpmyadmin:4.1.14.1
cpe:/a:phpmyadmin:phpmyadmin:4.1.14.2
Configuration 3
OR
cpe:/a:phpmyadmin:phpmyadmin:4.2.0
cpe:/a:phpmyadmin:phpmyadmin:4.2.1
cpe:/a:phpmyadmin:phpmyadmin:4.2.2
cpe:/a:phpmyadmin:phpmyadmin:4.2.3
cpe:/a:phpmyadmin:phpmyadmin:4.2.4
cpe:/a:phpmyadmin:phpmyadmin:4.2.5
cpe:/a:phpmyadmin:phpmyadmin:4.2.6
cpe:/a:phpmyadmin:phpmyadmin:4.2.7

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

1 change record found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2014-5273
NVD Published Date:
08/21/2014
NVD Last Modified:
10/16/2014