National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2014-8745 Detail

Description

Cross-site scripting (XSS) vulnerability in the Custom Search module 6.x-1.x before 6.x-1.13 and 7.x-1.x before 7.x-1.15 for Drupal allows remote authenticated users with the "administer taxonomy" permission to inject arbitrary web script or HTML via a taxonomy vocabulary label.

Source:  MITRE
Description Last Modified:  10/13/2014

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 3.5 LOW
Vector: (AV:N/AC:M/Au:S/C:N/I:P/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 6.8


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): Single
Confidentiality (C): None
Integrity (I): Partial
Availability (A): None
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://drupal.org/node/2248077
http://www.securityfocus.com/bid/67062
https://exchange.xforce.ibmcloud.com/vulnerabilities/92754
https://www.drupal.org/node/2247919 Patch
https://www.drupal.org/node/2247921 Patch

Technical Details

Vulnerability Type (View All)

  • Cross-Site Scripting (XSS) (CWE-79)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:drupal:custom_search_module:6.x-1.0:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:6.x-1.1:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:6.x-1.2:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:6.x-1.3:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:6.x-1.4:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:6.x-1.5:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:6.x-1.6:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:6.x-1.7:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:6.x-1.8:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:6.x-1.9:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:6.x-1.10:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:6.x-1.11:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:6.x-1.12:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:7.x-1.0:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:7.x-1.1:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:7.x-1.2:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:7.x-1.3:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:7.x-1.4:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:7.x-1.5:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:7.x-1.6:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:7.x-1.7:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:7.x-1.8:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:7.x-1.9:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:7.x-1.10:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:7.x-1.11:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:7.x-1.12:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:7.x-1.13:*:*:*:*:*:*:*
cpe:2.3:a:drupal:custom_search_module:7.x-1.14:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2014-8745
NVD Published Date:
10/13/2014
NVD Last Modified:
09/07/2017