National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2014-9293 Detail

Description

The config_auth function in ntpd in NTP before 4.2.7p11, when an auth key is not configured, improperly generates a key, which makes it easier for remote attackers to defeat cryptographic protection mechanisms via a brute-force attack.

Source:  MITRE      Last Modified:  12/19/2014

Quick Info

CVE Dictionary Entry:
CVE-2014-9293
Original release date:
12/19/2014
Last revised:
01/02/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
7.5 HIGH
Vector:
(AV:N/AC:L/Au:N/C:P/I:P/A:P) (legend)
Impact Subscore:
6.4
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://advisories.mageia.org/MGASA-2014-0541.html External Source CONFIRM http://advisories.mageia.org/MGASA-2014-0541.html
http://bk1.ntp.org/ntp-dev/ntpd/ntp_config.c?PAGE=diffs&REV=4b6089c5KXhXqZqocF0DMXnQQsjOuw Exploit External Source CONFIRM http://bk1.ntp.org/ntp-dev/ntpd/ntp_config.c?PAGE=diffs&REV=4b6089c5KXhXqZqocF0DMXnQQsjOuw
http://bugs.ntp.org/show_bug.cgi?id=2665 External Source CONFIRM http://bugs.ntp.org/show_bug.cgi?id=2665
http://marc.info/?l=bugtraq&m=142469153211996&w=2 External Source HP HPSBPV03266
http://marc.info/?l=bugtraq&m=142590659431171&w=2 External Source HP HPSBGN03277
http://marc.info/?l=bugtraq&m=142853370924302&w=2 External Source HP SSRT101872
http://marc.info/?l=bugtraq&m=144182594518755&w=2 External Source HP HPSBOV03505
http://rhn.redhat.com/errata/RHSA-2014-2025.html External Source REDHAT RHSA-2014:2025
http://rhn.redhat.com/errata/RHSA-2015-0104.html External Source REDHAT RHSA-2015:0104
http://secunia.com/advisories/62209 External Source SECUNIA 62209
http://support.ntp.org/bin/view/Main/SecurityNotice Vendor Advisory External Source CONFIRM http://support.ntp.org/bin/view/Main/SecurityNotice
http://www.kb.cert.org/vuls/id/852879 Third Party Advisory; US Government Resource External Source CERT-VN VU#852879
http://www.mandriva.com/security/advisories?name=MDVSA-2015:003 External Source MANDRIVA MDVSA-2015:003
http://www.oracle.com/technetwork/security-advisory/cpuoct2016-2881722.html External Source CONFIRM http://www.oracle.com/technetwork/security-advisory/cpuoct2016-2881722.html
http://www.securityfocus.com/bid/71757 External Source BID 71757
https://bugzilla.redhat.com/show_bug.cgi?id=1176032 External Source CONFIRM https://bugzilla.redhat.com/show_bug.cgi?id=1176032
https://h20564.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c04790232 External Source CONFIRM https://h20564.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c04790232
https://h20564.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c04916783 External Source CONFIRM https://h20564.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c04916783
https://kc.mcafee.com/corporate/index?page=content&id=SB10103 External Source CONFIRM https://kc.mcafee.com/corporate/index?page=content&id=SB10103
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20141222-ntpd External Source CISCO 20141222 Multiple Vulnerabilities in ntpd Affecting Cisco Products

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:ntp:ntp:*:*:*:*:*:*:*:*    versions up to (including) 4.2.7

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 14 change records found - show changes