National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2015-1536 Detail

Description

Integer overflow in the Bitmap_createFromParcel function in core/jni/android/graphics/Bitmap.cpp in Android before 5.1.1 LMY48I allows attackers to cause a denial of service (system_server crash) or obtain sensitive system_server memory-content information via a crafted application that leverages improper unmarshalling of bitmaps, aka internal bug 19666945.

Source:  MITRE
Description Last Modified:  09/30/2015

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 8.5 HIGH
Vector: (AV:N/AC:L/Au:N/C:P/I:N/A:C) (V2 legend)
Impact Subscore: 7.8
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): None
Availability (A): Complete
Additional Information:
Allows unauthorized disclosure of information
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
https://android.googlesource.com/platform/frameworks/base/+/d44e5bde18a41beda39d49189bef7f2ba7c8f3cb Vendor Advisory
https://groups.google.com/forum/message/raw?msg=android-security-updates/Ugvu3fi6RQM/yzJvoTVrIQAJ Vendor Advisory

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:o:google:android:*:*:*:*:*:*:*:*    versions up to (including) 5.1

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

6 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2015-1536
NVD Published Date:
09/30/2015
NVD Last Modified:
10/01/2015