National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2015-3749 Detail

Current Description

WebKit, as used in Apple iOS before 8.4.1 and Safari before 6.2.8, 7.x before 7.1.8, and 8.x before 8.0.8, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than other WebKit CVEs listed in APPLE-SA-2015-08-13-1 and APPLE-SA-2015-08-13-3.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: N/A
NVD score not yet provided.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.apple.com/archives/security-announce/2015/Aug/msg00000.html Mailing List Vendor Advisory
http://lists.apple.com/archives/security-announce/2015/Aug/msg00002.html Mailing List Vendor Advisory
http://lists.apple.com/archives/security-announce/2015/Sep/msg00003.html Mailing List Patch Vendor Advisory
http://lists.opensuse.org/opensuse-updates/2016-03/msg00132.html Mailing List Third Party Advisory
http://www.securityfocus.com/bid/76338 Third Party Advisory VDB Entry
http://www.securitytracker.com/id/1033274 Third Party Advisory VDB Entry
http://www.ubuntu.com/usn/USN-2937-1 Third Party Advisory
https://support.apple.com/HT205221 Vendor Advisory
https://support.apple.com/kb/HT205030 Vendor Advisory
https://support.apple.com/kb/HT205033 Vendor Advisory

Weakness Enumeration

CWE-ID CWE Name Source
CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:apple:itunes:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
12.2

Configuration 2 ( hide )
 cpe:2.3:a:apple:safari:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
From (including)
6.0
Up to (excluding)
6.2.8
 cpe:2.3:a:apple:safari:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
From (including)
7.0
Up to (excluding)
7.1.8
 cpe:2.3:a:apple:safari:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
From (including)
8.0
Up to (excluding)
8.0.8

Configuration 3 ( hide )
 cpe:2.3:o:apple:iphone_os:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (excluding)
8.4.1

Configuration 4 ( hide )
 cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:canonical:ubuntu_linux:15.10:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

9 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2015-3749
NVD Published Date:
08/16/2015
NVD Last Modified:
02/07/2019