National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2015-4100 Detail

Current Description

Puppet Enterprise 3.7.x and 3.8.0 might allow remote authenticated users to manage certificates for arbitrary nodes by leveraging a client certificate trusted by the master, aka a "Certificate Authority Reverse Proxy Vulnerability."

Source:  MITRE      Last Modified:  12/21/2017      View Analysis Description

Quick Info

CVE Dictionary Entry:
CVE-2015-4100
Original release date:
12/21/2017
Last revised:
01/09/2018
Source:
US-CERT/NIST

Impact

CVSS Severity (version 3.0):
CVSS v3 Base Score:
6.8 Medium
Vector:
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:H (legend)
Impact Score:
5.2
Exploitability Score:
1.6
CVSS Version 3 Metrics:
Attack Vector (AV):
Network
Attack Complexity (AC):
High
Privileges Required (PR):
Low
User Interaction (UI):
None
Scope (S):
Unchanged
Confidentiality (C):
High
Integrity (I):
None
Availability (A):
High
CVSS Severity (version 2.0):
CVSS v2 Base Score:
4.9 MEDIUM
Vector:
(AV:N/AC:M/Au:S/C:P/I:N/A:P) (legend)
Impact Subscore:
4.9
Exploitability Subscore:
6.8
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Medium
Authentication:
Required to exploit
Impact Type:
Allows unauthorized disclosure of information; Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
https://puppet.com/security/cve/CVE-2015-4100 Vendor Advisory External Source CONFIRM https://puppet.com/security/cve/CVE-2015-4100

Technical Details

Vulnerability Type (View All)

  • Improper Certificate Validation (CWE-295)

Change History 1 change record found - show changes