National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2015-4497 Detail

Current Description

Use-after-free vulnerability in the CanvasRenderingContext2D implementation in Mozilla Firefox before 40.0.3 and Firefox ESR 38.x before 38.2.1 allows remote attackers to execute arbitrary code by leveraging improper interaction between resize events and changes to Cascading Style Sheets (CSS) token sequences for a CANVAS element.

Source:  MITRE
View Analysis Description

Evaluator Description

CWE-416: Use After Free

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: N/A
NVD score not yet provided.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00013.html
http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00025.html
http://lists.opensuse.org/opensuse-updates/2015-09/msg00000.html
http://rhn.redhat.com/errata/RHSA-2015-1693.html
http://www.debian.org/security/2015/dsa-3345
http://www.mozilla.org/security/announce/2015/mfsa2015-94.html Vendor Advisory
http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
http://www.securityfocus.com/bid/76502
http://www.securitytracker.com/id/1033397
http://www.ubuntu.com/usn/USN-2723-1
http://www.zerodayinitiative.com/advisories/ZDI-15-406
https://bugzilla.mozilla.org/show_bug.cgi?id=1164766
https://bugzilla.mozilla.org/show_bug.cgi?id=1175278

Weakness Enumeration

CWE-ID CWE Name Source
NVD-CWE-Other Other NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:mozilla:firefox:40.0.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox_esr:38.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox_esr:38.0.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox_esr:38.0.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox_esr:38.1.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:mozilla:firefox_esr:38.2.0:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

6 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2015-4497
NVD Published Date:
08/29/2015
NVD Last Modified:
12/21/2016