National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2015-5279 Detail

Current Description

Heap-based buffer overflow in the ne2000_receive function in hw/net/ne2000.c in QEMU before 2.4.0.1 allows guest OS users to cause a denial of service (instance crash) or possibly execute arbitrary code via vectors related to receiving packets.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: N/A
NVD score not yet provided.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://git.qemu.org/?p=qemu.git;a=commit;h=7aa2bcad0ca837dd6d4bf4fa38a80314b4a6b755
http://lists.fedoraproject.org/pipermail/package-announce/2015-October/169036.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-October/169039.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-September/167369.html
http://lists.opensuse.org/opensuse-security-announce/2015-10/msg00019.html
http://rhn.redhat.com/errata/RHSA-2015-1896.html
http://rhn.redhat.com/errata/RHSA-2015-1923.html
http://rhn.redhat.com/errata/RHSA-2015-1924.html
http://rhn.redhat.com/errata/RHSA-2015-1925.html
http://www.debian.org/security/2015/dsa-3361
http://www.debian.org/security/2015/dsa-3362
http://www.openwall.com/lists/oss-security/2015/09/15/3
http://www.oracle.com/technetwork/topics/security/linuxbulletinoct2015-2719645.html
http://www.securityfocus.com/bid/76746
http://www.securitytracker.com/id/1033569
https://lists.gnu.org/archive/html/qemu-devel/2015-09/msg03984.html
https://security.gentoo.org/glsa/201602-01

Weakness Enumeration

CWE-ID CWE Name Source
CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
2.4.0


Change History

9 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2015-5279
NVD Published Date:
09/28/2015
NVD Last Modified:
12/27/2017